Project

General

Profile

Bug #960

Version 2.0 build error?

Added by Littlefield, Matthew over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
27 March 2012
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

I've upgraded to version 2.0 and rebuilt the cdb bash script and now when I run scons I get,

Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:22:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:28:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:36:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:60:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:68:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:73:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:78:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:83:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:88:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:93:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:98:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:103:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:108:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:113:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:118:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:123:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:128:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:133:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:138:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:143:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:148:
Error: Template class Hit not defined /home/matt/maus_littlefield/src/common_cpp/DataStructure/Hit-inl.hh:153:
Warning: Error occurred during reading source files
Warning: Error occurred during dictionary source generation
!!!Removing /home/matt/maus_littlefield/src/common_cpp/DataStructure//MausDataStructure.cc /home/matt/maus_littlefield/src/common_cpp/DataStructure//MausDataStructure.h !!!
Error: rootcint: error loading headers...
TypeError: Directory /home/matt/maus_littlefield/tests/integration/test_optics/optics found where file expected.:
  File "/home/matt/maus_littlefield/SConstruct", line 104:
    main()
  File "/home/matt/maus_littlefield/SConstruct", line 102:
    build_libraries(maus_root_dir_, env_)
  File "/home/matt/maus_littlefield/SConstruct", line 83:
    maus_build_tools.core_builder.build_cpp_tests(env)
  File "/home/matt/maus_littlefield/src/common_py/maus_build_tools/core_builder.py", line 98:
    LIBS= env['LIBS'] + ['MausCpp'])
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Environment.py", line 258:
    return MethodWrapper.__call__(self, target, source, *args, **kw)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Environment.py", line 222:
    return self.method(*nargs, **kwargs)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Builder.py", line 632:
    return self._execute(env, target, source, OverrideWarner(kw), ekw)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Builder.py", line 553:
    tlist, slist = self._create_nodes(env, target, source)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Builder.py", line 500:
    tlist = env.arg2nodes(target, target_factory, target=target, source=source)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Environment.py", line 482:
    v = node_factory(self.subst(v, **kw))
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Node/FS.py", line 1335:
    return self._lookup(name, directory, File, create)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Node/FS.py", line 1314:
    return root._lookup_abs(p, fsclass, create)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Node/FS.py", line 2211:
    result.diskcheck_match()
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Node/FS.py", line 2357:
    "Directory %s found where file expected.")
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Node/FS.py", line 384:
    return self.func(*args, **kw)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/scons-2.1.0.alpha.20110323-py2.7.egg/scons-2.1.0.alpha.20110323/SCons/Node/FS.py", line 405:
    raise TypeError(errorfmt % node.abspath)

Related issues

Is duplicate of MAUS - Bug #952: MAUS_0.2 build errorClosedRogers, Chris23 March 2012

Actions
#1

Updated by Littlefield, Matthew over 9 years ago

I think this might be a bzr problem as I dont think it is merging correctly when I try to updated my branch.

#2

Updated by Rogers, Chris over 9 years ago

It's actually a bug in the build script - #952

#3

Updated by Rogers, Chris over 9 years ago

  • Status changed from Open to Rejected

Rejected as dupe (but #952 is fixed)

Also available in: Atom PDF