Project

General

Profile

Feature #920

Clean up Mesh.hh

Added by Dobbs, Adam over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Simulation
Target version:
-
Start date:
28 February 2012
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

Mesh.hh produces complier warnings that makes our build output ugly and finding new compiler errors harder. Having looked at the file, I reckon this is a quick fix, probably just six lines, but I'm hesitant to do it myself. Sample output:

common_cpp -I/opt/ppd/mice/software/maus/maus-v0.1.3/third_party/build/root_v5.30.03/include -I/opt/ppd/mice/software/maus/maus-v0.1.3/third_party/build/geant4.9.2.p04/include -I. src/legacy/Interface/Mesh.cc
src/legacy/Interface/Mesh.hh: In member function 'void TwoDGrid::xLowerBound(const double&, int&) const':
src/legacy/Interface/Mesh.hh:200: warning: converting to 'int' from 'double'
src/legacy/Interface/Mesh.hh: In member function 'void TwoDGrid::yLowerBound(const double&, int&) const':
src/legacy/Interface/Mesh.hh:202: warning: converting to 'int' from 'double'
src/legacy/Interface/Mesh.hh: In member function 'void ThreeDGrid::xLowerBound(const double&, int&) const':
src/legacy/Interface/Mesh.hh:312: warning: converting to 'int' from 'double'
src/legacy/Interface/Mesh.hh: In member function 'void ThreeDGrid::yLowerBound(const double&, int&) const':
src/legacy/Interface/Mesh.hh:314: warning: converting to 'int' from 'double'
src/legacy/Interface/Mesh.hh: In member function 'void ThreeDGrid::zLowerBound(const double&, int&) const':
src/legacy/Interface/Mesh.hh:316: warning: converting to 'int' from 'double'
src/legacy/Interface/Mesh.hh: In member function 'void NDGrid::coordLowerBound(const double&, const int&, int&) const':
src/legacy/Interface/Mesh.hh:413: warning: converting to 'int' from 'double'


Related issues

Is duplicate of MAUS - Bug #498: Compiler warningsClosedRogers, Chris02 June 2011

Actions
Is duplicate of MAUS - Bug #349: Warning in Mesh compileClosedRogers, Chris28 February 2011

Actions
#1

Updated by Tunnell, Christopher over 10 years ago

Seen before, if that helps.

#2

Updated by Rogers, Chris over 10 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Fixed in 0.2.0

Also available in: Atom PDF