Project

General

Profile

Support #882

Unit testing for mappers

Added by Santos, Edward about 12 years ago. Updated about 12 years ago.

Status:
Rejected
Priority:
Normal
Category:
Testing
Target version:
Start date:
25 January 2012
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

Trying to write a cpp unit test for a Cpp mapper. During compile, I get the

"
undefined reference to <function>
"

error message. The issue is that my function declaration is found (compiler knows what the arguments of the function are...) and it also finds the function implementation IF the function is implemented inline in the header file. However, it misses it when the function is implemented in the .cc file. Is this a build feature?

Edward

Also available in: Atom PDF