Project

General

Profile

Support #873

Geometry Updates - Errors

Added by Littlefield, Matthew over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
common_py
Target version:
Start date:
20 January 2012
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

Hi,

I have now updated all of the things I've been working on and everything seems to be happy. Except I have two errors when I run run_tests.bash I don't there are to do with the stuff I've been working on. The errors are,


======================================================================
ERROR: Failure: ImportError (cannot import name HTTPSConnection)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/nose-1.0.0-py2.7.egg/nose/loader.py", line 390, in loadTestsFromName
    addr.filename, addr.module)
  File "/home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/nose-1.0.0-py2.7.egg/nose/importer.py", line 39, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/nose-1.0.0-py2.7.egg/nose/importer.py", line 86, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/home/matt/maus-littlefield/build/test_CouchDBDocumentStore.py", line 21, in <module>
    import couchdb
  File "build/bdist.linux-i686/egg/couchdb/__init__.py", line 9, in <module>
  File "build/bdist.linux-i686/egg/couchdb/client.py", line 34, in <module>
  File "build/bdist.linux-i686/egg/couchdb/http.py", line 17, in <module>
ImportError: cannot import name HTTPSConnection

======================================================================
ERROR: @brief walk up from $MAUS_ROOT_DIR and run pylint looking for errors
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/matt/maus-littlefield/build/test_python_style.py", line 124, in test_python_style
    ". Now "+str(n_errors))
RuntimeError: Number of python style errors has increased - Previously 648. Now 650
-------------------- >> begin captured stdout << ---------------------
650/648 style errors in following files (see tmp/pylint.out for details)
['src/common_py/Configuration.py', 'src/common_py/ErrorHandler.py', 'src/common_py/Go.py', 'src/common_py/SchemaSchema.py', 'src/common_py/__init__.py', 'src/common_py/make_canvas.py', 'src/input/InputCppDAQData/test_InputCppDAQData.py', 'src/input/InputPyEmptyDocument/InputPyEmptyDocument.py', 'src/input/InputPyEmptyDocument/test_InputPyEmptyDocument.py', 'src/input/InputPyJSON/InputPyJSON.py', 'src/input/InputPyJSON/test_InputPyJson.py', 'src/legacy/FILES/Models/Modules/MakeEMR.py', 'src/legacy/check_sync.py', 'src/legacy/fix_includes.py', 'src/map/MapCppPrint/test_MapCppPrint.py', 'src/map/MapCppSimulation/run_visualisation_for_tests.py', 'src/map/MapCppSimulation/test_MapCppSimulation.py', 'src/map/MapCppTrackerDigitization/test_MapCppTrackerDigitization.py', 'src/map/MapPyBeamMaker/test_MapPyBeamMaker.py', 'src/map/MapPyDoNothing/MapPyDoNothing.py', 'src/map/MapPyDoNothing/test_MapPyDoNothing.py', 'src/map/MapPyFakeTestSimulation/MapPyFakeTestSimulation.py', 'src/map/MapPyFakeTestSimulation/test_MapPyFakeTestSimulation.py', 'src/map/MapPyGroup/MapPyGroup.py', 'src/map/MapPyPrint/MapPyPrint.py', 'src/map/MapPyPrint/test_MapPyPrint.py', 'src/map/MapPyRemoveTracks/MapPyRemoveTracks.py', 'src/map/MapPyRemoveTracks/test_MapPyRemoveTracks.py', 'src/map/MapPyTOFPlot/MapPyTOFPlot.py', 'src/map/MapPyValidateSpill/MapPyValidateSpill.py', 'src/map/MapPyValidateSpill/test_MapPyValidateSpill.py', 'src/output/OutputPyDoNothing/OutputPyDoNothing.py', 'src/output/OutputPyDoNothing/test_OutputPyDoNothing.py', 'src/reduce/ReducePyDoNothing/ReducePyDoNothing.py', 'tests/integration/geometries/simulate_mice.py', 'tests/integration/test_simulation/test_help/test_help.py', 'tests/integration/test_simulation/test_rf/run_simulation.py', 'tests/integration/test_simulation/test_rf/test_broken_rf.py', 'tests/integration/test_simulation/test_rf/test_repeating_rf.py', 'tests/integration/test_simulation/test_rf/test_single_rf.py', 'tests/integration/test_simulation/test_virtual_planes/test_virt.py', 'tests/integration/test_utilities/simulate_mice.py', 'tests/integration/test_utilities/test_geometry/sim_config.py', 'tests/py_unit/test_always_true.py', 'tests/py_unit/test_cdb_mockup.py', 'tests/py_unit/test_cpp_unit.py', 'tests/py_unit/test_numpy.py', 'tests/py_unit/test_root_plot.py', 'tests/py_unit/test_schema_schema.py', 'tests/py_unit/test_spill_schema.py', 'tests/style/cpplint_exceptions.py', 'tests/style/test_cpp_style.py', 'tests/style/test_python_style.py']

--------------------- >> end captured stdout << ----------------------

the first error I have had seen the upgrade to 1.1 but the upgrade this week produced the pylint error

Also, I'm not sure what has happened to my test server? Any ideas?

Many thanks :-)


Files

install_log_err (68.8 KB) install_log_err Littlefield, Matthew, 20 January 2012 15:16
install_log_std (174 KB) install_log_std Littlefield, Matthew, 20 January 2012 15:16
#1

Updated by Rogers, Chris over 10 years ago

Looks like you are missing couchdb.

Try running third_party/bash/40python_extras.bash

I restarted your test job, the location of the build script changed (about 3 months ago) to ./install_build_test.bash, so I fixed that.

#2

Updated by Rogers, Chris over 10 years ago

I see errors in this one 'tests/integration/test_utilities/test_geometry/sim_config.py', which I think is yours?

#3

Updated by Littlefield, Matthew over 10 years ago

I still get the same connection error after I run python_extras?

That file was causing the problem I forgot it was there :-S its gone now though...

#4

Updated by Rogers, Chris over 10 years ago

Try rerunning also

./configure
source env.sh
#5

Updated by Littlefield, Matthew over 10 years ago

This hasn't worked either..

#6

Updated by Rogers, Chris over 10 years ago

Maybe rerun install_build_test then... I think it is a problem with your installation not the actual branch.

Nb: I got the test job running, it failed with

======================================================================
FAIL: TestGDMLFormatter::test_format
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jenkins/workspace/MAUS_littlefield/build/test_geometry/test_gdml_formatter.py", line 207, in test_format
    " found "+str(schema_found)+" times in "+filename)
AssertionError: Schema /home/jenkins/workspace/MAUS_littlefield/src/common_py/geometry/GDML_3_0_0/schema/gdml.xsd found 0 times in /home/jenkins/workspace/MAUS_littlefield/tmp/fastradModel.gdml
-------------------- >> begin captured stdout << ---------------------
Run information merged!
Formatted Configuration File
Formatted 1 of 6 Geometry Files
Formatted 2 of 6 Geometry Files
Formatted 3 of 6 Geometry Files
Formatted 4 of 6 Geometry Files
Formatted 5 of 6 Geometry Files
Formatted 6 of 6 Geometry Files
Format Complete
1maus number

--------------------- >> end captured stdout << ----------------------
#7

Updated by Littlefield, Matthew over 10 years ago

OK, I thought it was just my branch.

Ill fix that error I think I know what it is doing.

#8

Updated by Littlefield, Matthew over 10 years ago

I'm afraid install_build_test comes out with the same error ....

I don't really understand why but I have attached the build logs

#9

Updated by Littlefield, Matthew over 10 years ago

I have tried to clean install maus again but unfortunately i still get the http conncection error from couch db seen above. Any ideas?

#10

Updated by Littlefield, Matthew over 10 years ago

it looks similar to the libxslt/libxml-2 import errors we were getting before or maybe its an environment variable problem or something? I can't import the library from the command line either though

matt@Matts-laptop:~/maus-littlefield$ python 
Python 2.7 (r27:82500, Jul 20 2011, 10:42:20) 
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import couchdb
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No module named couchdb
>>>
#11

Updated by Rogers, Chris over 10 years ago

At the python command line try doing

from httplib import HTTPSConnection

and let me know what it says

#12

Updated by Rogers, Chris over 10 years ago

try:

easy_install couchdb
#13

Updated by Littlefield, Matthew over 10 years ago

from http gives

>>> from httplib import HTTPSConnection
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot import name HTTPSConnection
>>>

and easy install gives

root@Matts-laptop:/home/matt/maus-littlefield# easy_install couchdb
Searching for couchdb
Reading http://pypi.python.org/simple/couchdb/
Reading http://code.google.com/p/couchdb-python/
Best match: CouchDB 0.8
Downloading http://pypi.python.org/packages/2.6/C/CouchDB/CouchDB-0.8-py2.6.egg#md5=b47f8fe5f0c76d7c45bf8e4805d43de4
Processing CouchDB-0.8-py2.6.egg
creating /usr/local/lib/python2.6/dist-packages/CouchDB-0.8-py2.6.egg
Extracting CouchDB-0.8-py2.6.egg to /usr/local/lib/python2.6/dist-packages
Adding CouchDB 0.8 to easy-install.pth file
Installing couchdb-dump script to /usr/local/bin
Installing couchpy script to /usr/local/bin
Installing couchdb-load script to /usr/local/bin
Installing couchdb-replicate script to /usr/local/bin

Installed /usr/local/lib/python2.6/dist-packages/CouchDB-0.8-py2.6.egg
Processing dependencies for couchdb
Finished processing dependencies for couchdb

when thing i did notice when I was poking around was that couchdb was already installed on my laptop because its a standard ubuntu thing maybe I have the wrong version? I could uninstall it and run the maus installation again?

#14

Updated by Rogers, Chris over 10 years ago

You have to source env.sh first.

creating /usr/local/lib/python2.6/dist-packages/CouchDB-0.8-py2.6.egg
Extracting CouchDB-0.8-py2.6.egg to /usr/local/lib/python2.6/dist-packages

That is installing to your central python distribution, not the MAUS local one

#15

Updated by Littlefield, Matthew over 10 years ago

ah ok, so I have rerun easy_install couchdb

matt@Matts-laptop:~/maus-littlefield$ easy_install couchdb
Searching for couchdb
Best match: CouchDB 0.8
Processing CouchDB-0.8-py2.7.egg
CouchDB 0.8 is already the active version in easy-install.pth
Installing couchdb-dump script to /home/matt/maus-littlefield/third_party/install/bin
Installing couchpy script to /home/matt/maus-littlefield/third_party/install/bin
Installing couchdb-load script to /home/matt/maus-littlefield/third_party/install/bin
Installing couchdb-replicate script to /home/matt/maus-littlefield/third_party/install/bin

Using /home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/CouchDB-0.8-py2.7.egg
Processing dependencies for couchdb
Finished processing dependencies for couchdb

this seems to have worked ok but i still get the error in run_tests.bash

======================================================================
ERROR: Failure: ImportError (cannot import name HTTPSConnection)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/nose-1.1.2-py2.7.egg/nose/loader.py", line 390, in loadTestsFromName
    addr.filename, addr.module)
  File "/home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/nose-1.1.2-py2.7.egg/nose/importer.py", line 39, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/home/matt/maus-littlefield/third_party/install/lib/python2.7/site-packages/nose-1.1.2-py2.7.egg/nose/importer.py", line 86, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/home/matt/maus-littlefield/build/test_CouchDBDocumentStore.py", line 21, in <module>
    import couchdb
  File "build/bdist.linux-i686/egg/couchdb/__init__.py", line 9, in <module>
  File "build/bdist.linux-i686/egg/couchdb/client.py", line 34, in <module>
  File "build/bdist.linux-i686/egg/couchdb/http.py", line 17, in <module>
ImportError: cannot import name HTTPSConnection

which is the correct environment variable for this library?

#16

Updated by Littlefield, Matthew over 10 years ago

AH I think that couch db is now being sourced correctly because after I run ./configure and source env.sh and try importing couchdb from python I get

>>> import couchdb
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "build/bdist.linux-i686/egg/couchdb/__init__.py", line 9, in <module>

  File "build/bdist.linux-i686/egg/couchdb/client.py", line 34, in <module>
  File "build/bdist.linux-i686/egg/couchdb/http.py", line 17, in <module>
ImportError: cannot import name HTTPSConnection

which looks like couchdb is ok but httpsconnection is the problem? Ill keep trying :-)

#17

Updated by Littlefield, Matthew over 10 years ago

the ubuntu fix for this problem is to install the library

libssl-dev

Tah Dah!

#18

Updated by Rogers, Chris over 10 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Added documentation to install guide

Also available in: Atom PDF