Project

General

Profile

Bug #760

Fail to install on RAL PPD machines

Added by Rogers, Chris almost 10 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Tunnell, Christopher
Category:
Build System
Target version:
Start date:
21 October 2011
Due date:
% Done:

0%

Estimated time:
Workflow:

Description

Do the full build with e.g. install_then_build_then_test.bash

scons builds e.g. MapCppSimulation.py but fails to install them into build/ directory

#1

Updated by Rogers, Chris almost 10 years ago

e.g. after doing scons

Output from

ls build/*MapCpp* 
ls: build/*MapCpp*: No such file or directory

Output from

ls src/map/MapCppSimulation/build/
MapCppSimulation.os  MapCppSimulation.py  _MapCppSimulation.so  MapCppSimulation_wrap.cc  MapCppSimulation_wrap.os

Assigned to Tunnell, I assume you can have a go using mousehole and you have a ral ppd account but if not I can have a look...

#2

Updated by Rogers, Chris almost 10 years ago

I should say this is with a checkout of the release branch (0.0.8)

#3

Updated by Tunnell, Christopher almost 10 years ago

What machine? Can repeat on:

[tunnell@heplnx108 ~]$ hostname
heplnx108.pp.rl.ac.uk

but want to repeat on the exact same machine since sometimes there are oddities.

The trunk works on 105.

#4

Updated by Rogers, Chris almost 10 years ago

Probably dupe of #770

#5

Updated by Tunnell, Christopher almost 10 years ago

I'm going to close this since can't reproduce. Next time I look at least. I can try on a specific machine if we are sure it isn't a dupe.

#6

Updated by Ricciardi, Stefania almost 10 years ago

Hi,

I have got exactly the same behavious as Chris R. on heplnx108. I tried also to install MAU 0.0.8 under my home directory, so I think there are no symbolink links in my directory path, but have not managed to get a running version yet. I do not understand why: the machine is the same as the one used by Chris T.

#7

Updated by Rogers, Chris almost 10 years ago

Stefania, can you raise the issue with RAL PPD IT support? They probably know whether their are funny features in the home directory paths better than we do. Otherwise I'll do it next week. Can you just say on here when you've done it.

#8

Updated by Rogers, Chris almost 9 years ago

  • Status changed from Open to Rejected

No longer relevant

Also available in: Atom PDF