Support #724

SL4.4 MAUS 0.0.7 ofstream test failure

Added by Rogers, Chris about 12 years ago. Updated almost 12 years ago.

Target version:
Start date:
04 October 2011
Due date:
% Done:


Estimated time:


Email from Durga:


I am new to MICE - just getting started with MAUS and am having some teething trouble.

I tried installing the latest release -- the build seems to have worked, 
but it reports 1 failure when running the tests.
What I did: 
- got maus-latest-release.tar.gz
- unpacked, ran ./tests/integration/install_then_build_then_test.bash 

After I saw the failure, I re-tried source, scons build & bash run_tests.bash -- same result.

I don't want to clog your mail, so I have placed the logs here:

My system: SLF 4.4, Kernel: 2.6.9-89.0.3.ELsmp

I'd appreciate it if you could take a look and point out what I'm missing or doing incorrectly.

Thanks very much.



maus_test_log.txt (38.4 KB) maus_test_log.txt Tunnell, Christopher, 04 October 2011 17:03
scons_build_log.txt (9.13 KB) scons_build_log.txt Tunnell, Christopher, 04 October 2011 17:03

Updated by Rogers, Chris about 12 years ago

The test script failed to make a file in $MAUS_ROOT_DIR/tmp, like:


Can you see if this file exists and check you have read/write permission


For example, do "ls -lah" and look at the output permissions. If you are
curious, the error is coming from line 188-195 of



Updated by Rajaram, Durga about 12 years ago

The tmp directory and the files in there do have rw permissions.
[ the mice_module_test.dat file exists -- but I am not sure if its size looks reasonable to you ]

[durga@e907ana7 maus-latest-release]$ ls -l /disks/7/durga/m7/maus-latest-release/tmp/mice_module_test.dat
-rw-r--r--  1 durga e907 327 Oct  3 18:32 /disks/7/durga/m7/maus-latest-release/tmp/mice_module_test.dat

[durga@e907ana7 maus-latest-release]$ ls -lah tmp/
total 196K
drwxr-xr-x   2 durga e907 4.0K Oct  3 14:23 .
drwxr-xr-x  10 durga e907 4.0K Oct  4 10:36 ..
-rw-r--r--   1 durga e907  377 Oct  3 18:32 cpplint.out
-rw-r--r--   1 durga e907  633 Oct  3 18:31 g4_00.wrl
-rw-r--r--   1 durga e907 3.1K Oct  3 18:31 g4_01.wrl
-rw-r--r--   1 durga e907 3.1K Oct  3 18:31 g4_02.wrl
-rw-r--r--   1 durga e907  327 Oct  3 18:32 mice_module_test.dat
-rw-r--r--   1 durga e907 1.2K Oct  3 18:32 OutputPyJSON.tmp
-rw-r--r--   1 durga e907  97K Oct  3 18:35 pylint.out
-rw-r--r--   1 durga e907   21 Oct  3 18:32 test_core_go.tmp
-rw-r--r--   1 durga e907 2.0K Oct  3 18:32 test_cpplint.out
-rw-r--r--   1 durga e907 1.3K Oct  3 18:32 test_cpplint_out.out

Updated by Rogers, Chris about 12 years ago

File size is correct. So I can't imagine what went wrong! Only other thing I can think of is a buffering problem - attempt to read file before fout.close(). I guess if you're running over a network or something then that might happen... could try adding a sleep type command and see if that fixes it (in which case it is a bug) - could try inserting sleep line into ${MAUS_ROOT_DIR}/tests/cpp_unit/Config/ like:

#include <unistd.h>

[line 188]
  std::ofstream fout((test_module_path+test_module_name).c_str());
  fout << mice_mod_test.str();

(not tested) and see if that works.


Updated by Tunnell, Christopher about 12 years ago

Added your files too.

Do you have any sym links?

I'm trying to figure out why fstream woudln't work per this line

What type of filesystem is this? What are the contents of /disks/7/durga/m7/maus-latest-release/tmp/mice_module_test.dat?

(Just saw Chris's comments: could be a weird filesystem thing...)


Updated by Rajaram, Durga about 12 years ago

Hm..ok, let me see if I can get my hand on an SLF 5x machine and install there
(currently working on SLF 4.4)

Meanwhile, in response to your suggestions and questions:

-- No symbolic links to ${MAUS_ROOT_DIR} or ${MAUS_ROOT_DIR}/tmp
-- It is an ext3 fs; locally mounted disk
/dev/sdb1 /disks/7 ext3 defaults 1 2

[durga@e907ana7 maus-latest-release]$ df -h .
Filesystem Size Used Avail Use% Mounted on
/dev/sdb1 459G 355G 81G 82% /disks/7

-- Tried specifying the full path and filename explicitly in - same result.
-- Tried sleeping before and after the open/close like so:
std::ofstream fout("/disks/7/durga/m7/maus-latest-release/tmp/mice_module_test.dat");
fout << mice_mod_test.str();
Still fails
-- Content of dat file:
[durga@e907ana7 maus-latest-release]$ cat tmp/mice_module_test.dat
// A test module for MiceModule

Module TestModule {
Dimensions 39.0 260.0 100.0 cm
Position 10.0 20.0 30.0 cm
Rotation 0.0 0.0 90.0 degree
PropertyString Material AIR
PropertyBool Invisible 1
PropertyInt Copies 1
PropertyDouble GreenColour 0.5
PropertyDouble RedColour 1.0


Updated by Rogers, Chris almost 12 years ago

I think if this bug can't be repeated on another system, it has to go in rejected...


Updated by Tunnell, Christopher almost 12 years ago

  • Status changed from Open to Rejected

This is SL 4.4 which is like 6-10 years old, so it just sounds unsupported. At least we know it's an issue but he has it running on another machine.


Updated by Tunnell, Christopher almost 12 years ago

  • Subject changed from MAUS 0.0.7 test failure to SL4.4 MAUS 0.0.7 ofstream test failure

Also available in: Atom PDF