Project

General

Profile

Bug #430

xboa accelerator tools installs to wrong directory:

Added by Tunnell, Christopher over 10 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Build System
Target version:
Start date:
30 April 2011
Due date:
% Done:

0%

Estimated time:
Workflow:

Description

example:

-bash-3.2$ pwd
/home/hep/tunnell/maus/third_party/home/hep/tunnell/maus/third_party/install/share/xboa
-bash-3.2$ ls
data doc

this is on the RAL machines.


Related issues

Related to x-boa - Bug #465: xboa installs docs/data to wrong dirRejectedRogers, Chris24 May 2011

Actions
Related to MAUS - Bug #1240: xboa example data doesn't ship with Maus0.5ClosedRogers, Chris14 March 2013

Actions
#1

Updated by Tunnell, Christopher over 10 years ago

  • Target version changed from MAUS-v0.0.1 to Future MAUS release
#2

Updated by Tunnell, Christopher over 10 years ago

Is this worth me trying to include xboa to the build system again?

#3

Updated by Rogers, Chris over 10 years ago

I thought it's only the documentation and some sample files going to the wrong place - the code should install okay. There was some problem with setup.py so I hard coded the url of the share directory (which is what is going wrong).

If you look at setup.py

http://micewww.pp.rl.ac.uk/projects/x-boa/repository/entry/setup.py

There's:

sys.prefix+'/share/xboa/doc/'
sys.prefix+'/share/xboa/data/'

So the examples won't run properly and the docs will be hard to reach. But otherwise should be okay.

#4

Updated by Rogers, Chris about 10 years ago

  • Status changed from Open to Rejected
  • % Done changed from 0 to 100

I can't reproduce this bug. I checked (i) that xboa installs to correct directory and (ii) that xboa.examples.Example_1 gets file from correct directory (in this case $MAUS_ROOT_DIR/third_party/install/share/xboa).

#5

Updated by Rogers, Chris about 10 years ago

  • Status changed from Rejected to Open
  • % Done changed from 100 to 0

No, too easy. It's picking up the share directory of whoever last ran

python setup.py sdist
... reopened.

#6

Updated by Rogers, Chris about 10 years ago

Excerpt, for example, from log of MAUS_trunk build on test server - note /var/lib/... .../third_party/var/lib/.../

creating /var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/var
...
creating /var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/install/share/xboa/doc
copying README -> /var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/install/share/xboa/doc/
...
copying doc/Common.html -> /var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/var/lib/jenkins/jobs/MAUS_trunk/workspace/third_party/install/share/xboa/doc/

code is installed okay though:

copying build/lib.linux-x86_64-2.7/xboa/core/Hitcore.so -> /var/lib/jenkins/jobs/MAUS_rogers/workspace/third_party/install/lib/python2.7/site-packages/xboa/core
...
copying build/lib.linux-x86_64-2.7/xboa/test/BunchTest.py -> /var/lib/jenkins/jobs/MAUS_rogers/workspace/third_party/install/lib/python2.7/site-packages/xboa/test
#7

Updated by Rogers, Chris over 8 years ago

Fixed mysteriously as part of #1240

Also available in: Atom PDF