Project

General

Profile

Bug #374

Magnet status panel

Added by Nebrensky, Henry over 13 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Beam Line
Start date:
11 March 2011
Due date:
31 January 2014
% Done:

100%

Estimated time:

Description

Please can you check with Ian Mullacrane and Martin Hughes to see whether they've reached a consensus on what the status panel should indicate and whether any further work needs doing.


Related issues

Related to Operations - Bug #1131: Magnet On lamp placementClosedNebrensky, Henry07 September 201201 September 2013

Actions
Related to Operations - Bug #391: Q123 PS rack - power stripClosedNebrensky, Henry24 March 2011

Actions
#1

Updated by Nebrensky, Henry over 13 years ago

Saw Martin Hughes today:

- the D2 indicator is faulty: need to get replacement current sensor (+ some spares?) from the US

- still not agreed what the rack should indicate: MICE needs to decide.

At present it replicates the state of the "magnet on" lights.

Martin's advice (HN concurs) is that this is probably the best; it's simple to understand (a missing light indicates a lamp failure at the magnet) and the crate can do the job, whereas some of the fancier functionality that has been suggested would be both non-trivial to implement and likely to confuse shifters.

This implies we also need to think about deliberate tests of the magnet lights.

#2

Updated by Nebrensky, Henry about 13 years ago

During the dry run 23 March I set up a temporary webcam to watch the status light crate.

As expected, the (red) magnet lights came on one at a time as the magnets were set "on" (except DS and Q6 which were kept off, and D2 which has a faulty current sensor). Didn't get a chance to take a screenshot unfortunately.

As we were doing a trial run of the whole PPS, the proper PPS inputs should have been present.
The green "ISIS Area" and the "MICE Hall" searched lamps both came on OK, but not the "DSA Area"
Not sure if this is because the input is not yet connected, or a different crate fault.

#3

Updated by Nebrensky, Henry almost 13 years ago

The 8th June Hall meeting has a note that "Yes, the Q123 magnet status panel is part of the PPS".

N.B. All the status panel lamps were tested back in the autumn and some replaced, so the "DSA Area" lamp not lighting isn't just a blown bulb.

#4

Updated by Nebrensky, Henry over 12 years ago

Confusingly, I did query the "part of the PPS" statement mentioned above at the time, and have a dim recollection that it was then claimed to be a typo - i.e. NOT part of the PPS system (though connected physically to it).
My fault for not writing this down at the time.

Also, I have a sneaky feeling Q1 didn't light last time I saw it tested (probably the end Sept. run).

#5

Updated by MOM, Mice Operations Manager over 12 years ago

Martin Hughes has ordered 4x the failed current sensor
The replacement part number is CR7310-EL-240-.11-A-CD-ELR-I

Martin Hughes / Ian Mullacrane to organise installation.

Re Q1, should check at some point - could also be that the lamp on the magnet has failed!

#6

Updated by Coney, Linda over 12 years ago

  • Status changed from Open to In Progress
  • % Done changed from 0 to 50
#7

Updated by MOM, Mice Operations Manager over 12 years ago

We checked actual "magnet on" lamps on the magnets (except DS) during tests on 23rd - all working.

On status panel, Q1 and D2 lights both stayed off - i.e. Q1 indicator has failed since last year.
If panel is less reliable than the actual lamps, then we should get rid of it (but need to make manual check an annual? event!).

#8

Updated by Nebrensky, Henry almost 12 years ago

There was some discussion of this at Hall meetings in Jan/Feb.

Proposal was to remove the status panel and have an annual test/inspection instead, but I can't see this written down anywhere.

#9

Updated by Coney, Linda almost 12 years ago

As of my May MOM shift - looked again at the panel during May running - the Q1 and D2 panel lights were still not working. The DSA area searched light was also still not working.

Makes sense to remove the panel - there are other DSA searched lights available to see and the actual "magnet on" lamps work and can be seen by anyone accessing the areas.

Agreed should check they work periodically. Henry - please add these lights to your safety-critical checks.

#10

Updated by Nebrensky, Henry almost 12 years ago

(I've added Ken to this ticket)

Linda Coney wrote:

Makes sense to remove the panel...

I did agree with Ken at some point early in the year that we would "retire" said panel, and therefore institute direct visual checks, but I've no idea what needs to happen to make it official.
Proposal to + agreement from the Technical Board?

(This is why the panel was never repaired even after the spares had arrived).

...
- please add these lights to your safety-critical checks.

Note that checking the Magnet On lamps work has been on the MOM's Standing To-Do list since at least January - removing the panel merely changes the method of doing so.

#11

Updated by Coney, Linda almost 12 years ago

  • Due date set to 10 October 2012

Unless this has significant impact on PPS, it does not need to be a Technical Board level decision.

I will talk with Craig about it when he is back from holiday. If there are no issues, I see no reason to postpone this further.

I have added the visual inspection of the lights on the magnets to the Hall Preparation list on the micemine wiki.

#12

Updated by Coney, Linda almost 12 years ago

As to the "safety-critical check" comment - I should clarify.

Henry - you are in the process of creating a list of safety-critical items that need periodic maintenance and/or testing (#1006). I meant that the magnet-ON lights would be a good item to go on that list.

#13

Updated by Nebrensky, Henry almost 12 years ago

Makes sense to remove the panel...

Note though that these lamps are also on the Decay Solenoid (and of course that D1 and D2 are now interlocked with the PPS), so direct visual inspections are much trickier to schedule than they used to be (need DS run-able but ISIS open).

Given that we should still have the spares on site, would it be better to get the panel repaired and see if the new components are more reliable?

#14

Updated by Coney, Linda over 11 years ago

It was decided in the Hall meeting today to remove the panel as the panel lights have a shorter lifetime than the actual magnet-on lights.

It will be added to the electrical to-do list by Stewart and assigned to the appropriate person.

#15

Updated by Coney, Linda over 11 years ago

Since this has come up in the discussion about the rack this panel is in - what is the status on having the electrical team take this out?

It was decided back at the beginning of October to get rid of it (see above) - did Stewart add it to the electrical to-do list? I haven't seen it listed anywhere so I'm afraid it's dropped off the radar.

#16

Updated by Nebrensky, Henry over 11 years ago

It's not on the list from 23/01/13 given in yesterday's Hall Meeting.

It's not clear to me who should be in charge of the job, and also what it actually involves.
I'll try to get the whole Q123 rack / Magnet-On Lamps thing clarified next time DL come down.

#17

Updated by Nebrensky, Henry over 11 years ago

Note that the "Magnet Status Panel" also describes itself as a power supply unit:

and talks to PSUs etc.:

Talking to Martin Hughes it looks like it can't simply be removed as hoped - would need to be replaced instead.
Hopefully something will come out of CM35...

#18

Updated by Nebrensky, Henry over 11 years ago

  • Due date changed from 10 October 2012 to 26 April 2013

Andy Gallagher to talk to Martin Hughes. We have the parts already, so I tend towards repairing it at this point.

The larger picture however is that this is actually waiting on #1131 and whether or not the whole Magnet-On lamp system needs rebuilding!
For now I've moved the due date back to the end of the April shutdown.

#19

Updated by MOM, Mice Operations Manager over 11 years ago

  • Assignee changed from MOM, Mice Operations Manager to Nebrensky, Henry
#20

Updated by Nebrensky, Henry about 11 years ago

MH has passed the spare parts on to AG who will fit them in the crate; this will leave us with a working magnet status panel we can use annually to check the lamps themselves are still working.

Not decided what to do regarding the PPS indicators at the left end of the panel.

#21

Updated by Nebrensky, Henry about 11 years ago

  • Due date changed from 26 April 2013 to 05 October 2013

Spoke to AG today - he believes that the unit can be made to control the lights subject to the state of the area (i.e. don't illuminate if there can be nobody there to warn). (Confusingly this contradicts what I've been told elsewhere, that this would be beyond the unit's capability, but no matter).

In any case, I made an executive decision:

the Magnet-On lamps will be lit at all times their magnet is on, and if all lamps on a magnet are correctly lit then the corresponding indicator on the panel will illuminate.

This lets us do the annual Magnet-On lamps check without needing DSA or synch access to view the lamps directly, and skipping the PPS/search control feature means that the lights will indeed be on when we do the check! (Otherwise need to have DS cold and ISIS open at the same time which isn't a likely combo).

The panel has now returned from DL and been replaced, but internal testing suggests an issue with the D1 lamp. This may be due to the installation work for #1131 and will be investigated tomorrow. Plan is then to test with magnets in 2 weeks' time.

#22

Updated by Nebrensky, Henry about 11 years ago

  • Due date changed from 05 October 2013 to 10 May 2013
#23

Updated by Nebrensky, Henry about 11 years ago

Looked today - the DSA Search lamp is on, but ISIS search lamp is off.

ISIS synch LED screen reports HV On and Beam On, and the blue lights are on in DSA.
(So this seems to have flipped since update #9)

Also the Beam On lamp above the DSA fire exit is still off - need to find out if that's ours (=Muon Beam On) or theirs (=ISIS Beam On).

#24

Updated by Nebrensky, Henry about 11 years ago

It's since been confirmed that the Beam On lamp above the DSA fire exit is part of the ISIS PPS and their responsibility, not MICE'.
(It's also been fixed)

I've added a small "ISIS Beam On" label below it for future reference.

#25

Updated by Nebrensky, Henry about 11 years ago

We ran up the magnets yesterday, and checked the status panel; after tweaking the current sensors all magnet lights except D2 and solenoid (actually off) were on.

D2 will be investigated further.
D2 and Q789 now have only 1 lamp on the magnet itself. Will need to re-tweak current sensors after the extra lamps have been fitted, to ensure that the light will indeed go out, even if only one lamp fails.

#26

Updated by Nebrensky, Henry almost 11 years ago

  • Due date changed from 10 May 2013 to 01 September 2013

Q789 have had new lamps fitted and tested.

We went through all of Q4 - Q9: both the 2 lamps on the magnet and the indicator on the status panel light when magnet is on.
If one lamp disconnected (simulated bulb failure) then the status panel indicator goes off.

Couldn't get ISIS access else we'd have checked those too - will do once D2 gets lamp fitted.

Deadline set for end of this shutdown.

#27

Updated by Nebrensky, Henry almost 11 years ago

Went through Q123 and D1 today without any problems.

Tested D2 - current sensor needed tweaking to make status light come on. Check panel again when D2 replaced next week.

Synch and DSA both open, and none of the PPS lamps are on.

#28

Updated by Nebrensky, Henry almost 11 years ago

  • Due date changed from 01 September 2013 to 31 January 2014

If D2 OK next week, then conventional magnets done.

Still need to check DS lamps once the DS PSU has been replaced (speculative deadline update).

#29

Updated by Nebrensky, Henry almost 11 years ago

Briefly ran D2 today - status indicator came on as expected.

So conventional magnets done, but still need to check DS once the DS PSU has been replaced. Note that this includes confirming role of the Magnet-On lamp in ISIS vault mentioned in #1131.

#30

Updated by Nebrensky, Henry over 9 years ago

Checked today that all the DS lamps come on, and set the current sensor to detect bulb failures (tested one at a time with both the lamps in the DSA, but NOT that in the synch).
The lamp in the ISIS vault is indeed for the DS.

Still need to confirm once the PSU is completely finished that the lamps are still active (at all).

#31

Updated by Nebrensky, Henry over 9 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 50 to 100

The DS PSU is installed - hopefully for good - and the entire beamline lights up:

The PPS status lamps remain a mystery, but are declared irrelevant.

Also available in: Atom PDF