Project

General

Profile

Bug #368

MiceModule tests fail because of bad write

Added by Rogers, Chris almost 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
common_cpp
Target version:
Start date:
07 March 2011
Due date:
% Done:

100%

Estimated time:
Workflow:

Description

The MiceModules cpp test requires write to disk - this is broken and causes the test to fail. Requirement is to rehack MiceModules so we don't need a disk write (use an istream rather than a filename in function call)


Related issues

Is duplicate of MAUS - Bug #375: ReadModulesTest fails on SL4.8RejectedRogers, Chris15 March 2011

Actions
#1

Updated by Rogers, Chris almost 12 years ago

See tempfile python module...

#2

Updated by Rogers, Chris almost 12 years ago

duped by #375

#3

Updated by Tunnell, Christopher almost 12 years ago

Do we disable the test in the meantime? Or remove SL4.8 from supported?

#4

Updated by Rogers, Chris almost 12 years ago

I disabled the test in rogers... awaiting merge. I'll leave the issue open because I don't want to lose the test.

#5

Updated by Rogers, Chris almost 12 years ago

Fixed in maus_rogers

#6

Updated by Tunnell, Christopher over 11 years ago

  • Target version changed from MAUS-v0.0.1 to Future MAUS release
#7

Updated by Rogers, Chris over 11 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Fixed - uses /tmp/ directory

#8

Updated by Tunnell, Christopher over 11 years ago

  • Target version changed from Future MAUS release to MAUS-v0.0.1

Also available in: Atom PDF