Project

General

Profile

Bug #366

MathUtils::Tanh test failing

Added by Rogers, Chris about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
common_cpp
Target version:
Start date:
04 March 2011
Due date:
% Done:

100%

Estimated time:
Workflow:

Description

From Tunnell:

Hey,

I get this error:

tests/cpp_unit/Interface/MathUtilsTest.cpp:294: Failure
Value of: tanh((x+_x0)/_lambda)-tanh((x-_x0)/_lambda)
Actual: 0.67945553896577626
Expected: 2.*_d_tanh.GetDoubleTanh(x, 0)
Which is: 0.67945553896577615
[ FAILED ] TanhTest.GetDoubleTanhTest (4 ms)

In a ton of places. Can you look?

http://micetest.pp.rl.ac.uk/job/MAUS_nonVMs_nightly/slaves=heplnx101/24/console

It's not on all systems though.

#1

Updated by Rogers, Chris about 11 years ago

Compares numerical derivative vs analytical derivative - so sensitive to machine precision... probably the issue...

#2

Updated by Rogers, Chris about 11 years ago

Actually slightly different issue, but floating point precision problem nonetheless...

fixed in rogers dev, running hudson now...

#3

Updated by Rogers, Chris about 11 years ago

Pushed fix to the trunk - but I can't reproduce it on my machine, so can only hope it is fixed...

#4

Updated by Tunnell, Christopher about 11 years ago

ah right, you pushed it (I was trying to merge it and got really confused because the commit was there, but the timestamp was wrong). :)

I'll start the testing on the wide range of machines if they aren't already running

#5

Updated by Rogers, Chris about 11 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF