Project

General

Profile

Bug #349

Warning in Mesh compile

Added by Rogers, Chris almost 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
common_cpp
Target version:
Start date:
28 February 2011
Due date:
% Done:

100%

Estimated time:
Workflow:

Description

MAUS build makes a bunch of warning messages like:

src/common/Interface/Mesh.hh: In member function 'void TwoDGrid::xLowerBound(const double&, int&) const':
src/common/Interface/Mesh.hh:199: warning: converting to 'int' from 'double'
src/common/Interface/Mesh.hh: In member function 'void TwoDGrid::yLowerBound(const double&, int&) const':
src/common/Interface/Mesh.hh:201: warning: converting to 'int' from 'double'
src/common/Interface/Mesh.hh: In member function 'void ThreeDGrid::xLowerBound(const double&, int&) const':
src/common/Interface/Mesh.hh:311: warning: converting to 'int' from 'double'
src/common/Interface/Mesh.hh: In member function 'void ThreeDGrid::yLowerBound(const double&, int&) const':
src/common/Interface/Mesh.hh:313: warning: converting to 'int' from 'double'
src/common/Interface/Mesh.hh: In member function 'void ThreeDGrid::zLowerBound(const double&, int&) const':
src/common/Interface/Mesh.hh:315: warning: converting to 'int' from 'double'
src/common/Interface/Mesh.hh: In member function 'void NDGrid::coordLowerBound(const double&, const int&, int&) const':
src/common/Interface/Mesh.hh:412: warning: converting to 'int' from 'double'


Related issues

Is duplicate of MAUS - Bug #498: Compiler warningsClosedRogers, Chris02 June 2011

Actions
Has duplicate MAUS - Feature #920: Clean up Mesh.hh ClosedRogers, Chris28 February 2012

Actions
#1

Updated by Tunnell, Christopher almost 12 years ago

  • Priority changed from Normal to Low
#2

Updated by Rogers, Chris almost 12 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Fixed a week or two back... can't remember which commit

Also available in: Atom PDF