Project

General

Profile

Bug #345

ELFCLASS build install error

Added by Tunnell, Christopher over 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Tunnell, Christopher
Category:
Build System
Target version:
Start date:
23 February 2011
Due date:
% Done:

100%

Estimated time:
Workflow:

Description

Reported by Tim Carlisle:

Making include/compiledata.h
Running /home/carlisle/maus-nightly/third_party/build/root_v5.28.00/cint/ROOT/co
nfigcint.mk
Making cint/cint/inc/configcint.h
bin/rmkdepend -R -fcint/cint/src/g__cfunc.d -Y -w 1000 -- -pipe -m64 -Wall -W -f
PIC -Iinclude -DR__HAVE_CONFIG -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL
-DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__64BIT -DG__HAVE_CONFIG -DG__NO
MAKEINFO -DG__CINTBODY -I/home/carlisle/maus-nightly/third_party/build/root_v5.2
8.00/cint/cint/inc -I/home/carlisle/maus-nightly/third_party/build/root_v5.28.00
/cint/cint/src -I/home/carlisle/maus-nightly/third_party/build/root_v5.28.00/cin
t/cint/src/dict -pthread -I. -- /home/carlisle/maus-nightly/third_party/build/ro
ot_v5.28.00/cint/cint/src/g__cfunc.c
make: bin/rmkdepend: Command not found
make: *** [cint/cint/src/g__cfunc.o] Error 127
FAIL: Failed to configure/make
Traceback (most recent call last):
  File "/home/carlisle/maus-nightly/third_party/install/bin/scons", line 187, in                                   <module>
    import SCons.Script
  File "/home/carlisle/maus-nightly/third_party/install/lib/scons-2.0.1/SCons/Sc                                  ript/__init__.py", line 76, in <module>
    import SCons.Environment
  File "/home/carlisle/maus-nightly/third_party/install/lib/scons-2.0.1/SCons/En                                  vironment.py", line 54, in <module>
    import SCons.Platform
  File "/home/carlisle/maus-nightly/third_party/install/lib/scons-2.0.1/SCons/Pl                                  atform/__init__.py", line 52, in <module>
    import tempfile
  File "/home/carlisle/maus-nightly/third_party/install/lib/python2.7/tempfile.p                                  y", line 34, in <module>
    from random import Random as _Random
  File "/home/carlisle/maus-nightly/third_party/install/lib/python2.7/random.py"                                  , line 48, in <module>
    from binascii import hexlify as _hexlify
ImportError: /home/carlisle/maus-nightly/third_party/install/lib/python2.7/lib-d                                  ynload/binascii.so: wrong ELF class: ELFCLASS64

and the issue is that he sourced his G4MICE setup before trying to install MAUS. This will create an issue because future programs will see both 32-bit (G4MICE) and 64-bit (his machine) libraries and get confused.

No data to display

Also available in: Atom PDF