Project

General

Profile

Feature #296

verify tracker digitization

Added by Tunnell, Christopher over 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Category:
Tracker
Target version:
Start date:
25 January 2011
Due date:
% Done:

100%

Estimated time:
Workflow:

Description

need somebody from tracker group to make sure that it's doing the right thing


Related issues

Related to MAUS - Feature #295: verify TOF digitizationRejectedKaradzhov, Yordan25 January 2011

Actions
Is duplicate of MAUS - Bug #222: SciFiSD doesn't support pileup (creates new hits)RejectedTunnell, Christopher22 November 2010

Actions
Blocks MAUS - Feature #508: Cleanup Tracker DigitizationClosedSantos, Edward24 June 201124 June 2011

Actions
#1

Updated by Tunnell, Christopher over 10 years ago

(deleted)

#2

Updated by Tunnell, Christopher over 10 years ago

Email sent to Linda Coney per request about what Chris Heidt could do as a starting project:

Dear Linda,

You asked me about useful stuff Chris Heidt could do. This is more from a software perspective since I'm not part of the tracker group, but I mentioned wanting to do something like with with Malcolm (who sounded thrilled) so don't think it's too crazy.

At the next CM, I'm presenting a 'reconstruction framework' which I've been showing to various people. It incorporates a data-structure, spill-structure, better 'DAQ-like' dataflow, etc.. Rogers and Colling like it but also want to use it, so here's what needed from that perspective.

Within specifically the MC dataflow, the steps are MC (energy deposited in some place with some time) then digitization (ADC/TDC counts), then space points, then fitting. I'm trying to take baby steps to build from the ground up. Before we get lost in the world of fits (since people believe the space-point and digitization stuff) we need somebody to verify that the digitization is doing something sane from a physics perspective.

What I envision is that this person is responsible for the digitization step. This person will sign off for the tracker group that the digitization can be used in a release. This person should probably also write a few more tests to it since I've only put in a few and don't know how the tracker works well enough. This person should add to the documentation that I have put in, add some tests, but also take the logic of the digitization and run it by people in the tracker group. I really want a name and date of something I can point to saying that "the digitization works because the tracker group of X, Y, Z said it did". There are also dead parts of code and dead datacards that just need to be removed. This task not only has some physics in it in terms of understanding the physics of detectors but also will give the person some familiarity with the code.

It's a perfect starter project for a graduate student and should be done within the timescale of month(s). It could even (for the enthusiastic graduate student who wants exposure) be turned into a short note, but at least few paragraphs on the logic of the digitization is needed within the documentation of our code.

Cheers,
Chris

#3

Updated by Tunnell, Christopher over 10 years ago

  • Category changed from 31 to Tracker
#4

Updated by Rogers, Chris over 10 years ago

  • Assignee set to Aslaninejad, Morteza
#5

Updated by Tunnell, Christopher over 10 years ago

  • Assignee deleted (Aslaninejad, Morteza)

Make sense of constants.

#6

Updated by Santos, Edward about 10 years ago

  • Assignee set to Santos, Edward

This can be closed.

#7

Updated by Rogers, Chris almost 10 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Closed then

#8

Updated by Rogers, Chris almost 10 years ago

  • Target version changed from Future MAUS release to MAUS-v0.0.9

Also available in: Atom PDF