Project

General

Profile

Bug #1957

Segmentation Fault when using MAUS 3.1.2

Added by Young, Alan over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
21 February 2018
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I'm getting a segmentation fault when running the scattering analysis code(c++) using MAUS 3.1.2. The fault does not arise when running the code with MAUS 3.1.0.

The line that causes the problem is:

output->cd();

where output has been previously defined in:

outfile = new TFile(outname.c_str(), "recreate");

The following error message is returned:

  • Break *** segmentation violation

===========================================================
There was a crash.
This is the entire stack trace of all threads: ===========================================================
#0 0x0000003883aac82e in waitpid () from /lib64/libc.so.6
#1 0x0000003883a3e479 in do_system () from /lib64/libc.so.6
#2 0x00007fbfacae406a in TUnixSystem::StackTrace() () at /home/alan/maus/MAUS-v3.1.2/third_party/source/root_v5.34.36/core/unix/src/TUnixSystem.cxx:2172
#3 0x00007fbfacae619c in TUnixSystem::DispatchSignals(ESignals) () at /home/alan/maus/MAUS-v3.1.2/third_party/source/root_v5.34.36/core/unix/src/TUnixSystem.cxx:1294
#4 <signal handler called>
#5 0x0000000000448b50 in MCSAnalysis::make_beam_histograms(Collection, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >) () at MCSAnalysis.cpp:2356
#6 0x000000000042d3d8 in MCSAnalysis::dataSelection() () at MCSAnalysis.cpp:335
#7 0x000000000042c084 in MCSAnalysis::Execute(int) () at MCSAnalysis.cpp:211
#8 0x000000000041ff5c in main () at MCSUnfolding.cpp:207 ===========================================================

The lines below might hint at the cause of the crash.
If they do not help you then please submit a bug report at
http://root.cern.ch/bugs. Please post the ENTIRE stack trace
from above as an attachment in addition to anything else
that might help us fixing this issue. ===========================================================
#5 0x0000000000448b50 in MCSAnalysis::make_beam_histograms(Collection, std::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::basic_string<char, std::char_traits<char>, std::allocator<char> >) () at MCSAnalysis.cpp:2356
#6 0x000000000042d3d8 in MCSAnalysis::dataSelection() () at MCSAnalysis.cpp:335
#7 0x000000000042c084 in MCSAnalysis::Execute(int) () at MCSAnalysis.cpp:211
#8 0x000000000041ff5c in main () at MCSUnfolding.cpp:207 ===========================================================

#1

Updated by Franchini, Paolo over 4 years ago

  • Assignee set to Franchini, Paolo

Please remember to fill the Assignee part otherwise I would just forget to check the issues.

Have you sorted this out? If not...

Are you always using the very same file?

I have no idea what your code is doing and at which stage is failing. Just a shot in the dark: could you please try with same run but reconstructed with 3.1.2 as you can find here http://reco.mice.rl.ac.uk/?

#2

Updated by Franchini, Paolo over 3 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

I assumed Alan has moved over with a more recent release. Still not sure what the problem was.

Also available in: Atom PDF