Project

General

Profile

Bug #1945

Problem building MAUS

Added by Lord, Tom almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
21 October 2017
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I've been having problems building MAUS, it's running into errors configuring CMake, but not really sure what the root of the problem is.


Files

install.log (17.2 MB) install.log Lord, Tom, 21 October 2017 13:38
CMakeError.log (463 KB) CMakeError.log Lord, Tom, 23 October 2017 14:26
CMakeOutput.log (1.89 MB) CMakeOutput.log Lord, Tom, 23 October 2017 14:26
#1

Updated by Lord, Tom almost 4 years ago

  • Category set to Build System
#2

Updated by Lord, Tom almost 4 years ago

  • Target version set to MAUS-v3.0.0
#3

Updated by Dobbs, Adam almost 4 years ago

  • Assignee set to Dobbs, Adam

Hi Tom,

It looks like an error building cmake. Could you add the files:

/storage/epp2/phumhf/maus/release/third_party/build/cmake-3.5.2/CMakeFiles/CMakeOutput.log
/storage/epp2/phumhf/maus/release/third_party/build/cmake-3.5.2/CMakeFiles/CMakeError.log

to the issue tracker please.

AD

#4

Updated by Lord, Tom almost 4 years ago

Hi Adam,

I've attached the two log files as requested

Tom

#5

Updated by Dobbs, Adam almost 4 years ago

OK, it seems cmake cannot find the gtk2 development package on the Warwick system:

CMake Error at Modules/FindGTK2.cmake:238 (message):
Include file does not exist
Call Stack (most recent call first):
Modules/FindGTK2.cmake:781 (_GTK2_SIGCXX_GET_VERSION)

There a few ways around this:

  • Ask your sys admin to install this package
  • Ask your sys admin to install a modern cmake version to save us building it, the comment out the line which builds cmake in the MAUS file third_party/build_all.bash
  • Ask Paolo how he did it!
#6

Updated by Franchini, Paolo almost 4 years ago

Thanks Adam, we will solve this internally and close the ticket once the installation is done.

#7

Updated by Franchini, Paolo almost 4 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Installation done, problems solved at the admin side.

Also available in: Atom PDF