Project

General

Profile

Bug #1943

Problem making MAUS v2.9.1 on Ubuntu 16.04

Added by Boyd, Steven about 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Build System
Target version:
Start date:
11 October 2017
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I've run into several issues compiling third party software due to missing libraries etc which I've dealt with to date. However can't even tell what the problem is here. Seems as if G4analysis library is not found but I could be misdiagnosing this. During G4 compile I note a message

-- Installing: /home/boyd/mice_analysis/MAUS-v2.9.1/third_party/install/lib/libG4analysis.so
-- Set runtime path of "/home/boyd/mice_analysis/MAUS-v2.9.1/third_party/install/lib/libG4analysis.so" to ""

Don't know if that's the issue though. Install.log has been attached.


Files

install.log (22.5 MB) install.log Boyd, Steven, 11 October 2017 15:44
install.log (22.8 MB) install.log Boyd, Steven, 12 October 2017 13:06
install.log (11.7 MB) install.log Boyd, Steven, 13 October 2017 11:24
#1

Updated by Dobbs, Adam about 4 years ago

Hi Steve,

OK, I have looked through your log. The G4Analysis issue has cropped up before, even when, as here, GEANT4 looks like it has built perfectly well. I note a few other issues however:

  • CDB third party libs failed to build - install yacc (yet-another-compiler) from the Ubuntu repositories (I'll add it to the list of dependencies)
  • DOxygen failed to build as bison was missing - install bison and libbison-dev (already a listed dependency, best to make sure everything else listed at http://micewww.pp.rl.ac.uk/projects/maus/wiki/Install, Ubuntu section is installed too (some of the lib names may need a little tweaking when searching for them from the repos))
  • G4Beamline failed to build - but you probably won't need it, nor does anything else depend on it, so can ignore
Other notes:
  • The latest MAUS version is 3.0.0, I suggest installing that rather than 2.9.1
  • GCC will build by default as a third party, however Ubuntu 16 has a sufficiently modern compiler built-in, so you can save huge amount of time and disk space by building with:

./install_build_test.bash --use-system-gcc true -j N

where N is the number of cores you wish to build on (note the gap between the -j and the N).

I strongly suggest rebuilding in clean directory.

Let me know how that goes. If it fails again, we will try something else.

AD

#2

Updated by Boyd, Steven about 4 years ago

Followed all that - installed all indicated packages, built MAUS-v.3.0 from scratch. Unfortunately it still fails just after compiling maus-apps. install.log attached....

#3

Updated by Dobbs, Adam about 4 years ago

Hi Steve,

Hmmmm, interesting. OK -- could you please send me the exact set of commands you used to start the build, right down to making the directory. It's still hanging on the G4Analysis library...

Best, AD

#4

Updated by Boyd, Steven about 4 years ago

It's the basic build. I download the source tarball

gunzip MAUS-v.3.0.0.tar.gz
tar xvf MAUS-v3.0.0.tar
cd MAUS-v3.0.0
./install_build_test.bash

  • then I let it go....and go....until it hits the G4analysis issue. The "set runtime path " message happens with G4analysis, G4digit, G4error_propagation, and in fact all the other libG4*.so libraries.

All the libraries were built and exist in MAUS-v3.0.0/third_party/install/lib

In this directory there is also a Geant4-9.6.2 directory which seems to contain a self-referential directory link.
In MAUS-v3.0.0/third_party/install/lib/Geant4-9.6.2 there is a directory Linux-g++ which seems to be a link to '..'
(e.g. ls -l this Geant4 directory gives 'Linux-g++ -> ..'). Don't know if that's anything.1

#5

Updated by Boyd, Steven about 4 years ago

Incidentally - I'll be there tomorrow with my laptop so you can look at the build "in person" if you like....

#6

Updated by Dobbs, Adam about 4 years ago

Excellent - yes a look in person would be helpful. Meanwhile, try using this build command, again in a clean directory:

./install_build_test.bash --use-system-gcc true

This will tell it to build with the Ubuntu in-house gcc, not build gcc separately, which may help.

I have seen this G4 issue before (both Jan and myself have encountered it), but never firmly diagnosed the cause...

#7

Updated by Dobbs, Adam about 4 years ago

The build on Tom's laptop is going well incidentally... I'll race you to a working MAUS version at Warwick.

#8

Updated by Boyd, Steven about 4 years ago

Interesting. The build using Ubuntu's native gcc compiler seems to have worked (and the geant messages look like red herrings). Well, sort of worked. It seems to have crashed in the unit tests but I can't work out why. Install.log is attached.

#9

Updated by Franchini, Paolo almost 4 years ago

  • Assignee changed from Dobbs, Adam to Franchini, Paolo

Hi Steve,

could you please try to run the test test_cpp_unit.py manually?

#10

Updated by Franchini, Paolo over 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

I assume we can close this.

Also available in: Atom PDF