Project

General

Profile

Bug #1936

Revision 1210 does not appear to fix cdb-C++ bug

Added by Greis, Jan over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
09 June 2017
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I've tried installing the current version of the merge branch on the Warwick cluster (Red Hat 6 I believe) and what I'm guessing is the cdb-C++ bug mentioned on https://micewww.pp.rl.ac.uk/projects/maus/wiki/ReleaseStatus persists. Specifically, I get this error:
In file included from src/common_cpp/Utils/TOFCalibrationMap.cc:21:0:
third_party/install/include/cdb-c++/calibration/calibration.h:9:58: fatal error: generated/soapCalibrationImplPortBindingProxy.h: No such file or directory
#include<generated/soapCalibrationImplPortBindingProxy.h>
I have verified that the changes from 1210 are present in the branch I tried to install.
Logfile attached.


Files

install.log.tar.gz (1.03 MB) install.log.tar.gz Greis, Jan, 09 June 2017 14:57
#1

Updated by Rajaram, Durga over 4 years ago

  • The failure stems from an earlier failure to install gsoap [ look in the log for gsoap ]
  • And gosap failed because -- again from your log:
    make[3]: Entering directory `/home/phrnat/MAUS/maus-v2.9.1/third_party/build/gsoap-2.8/gsoap/src'
    /bin/sh ../../ylwrap soapcpp2_yacc.y y.tab.c soapcpp2_yacc.c y.tab.h `echo soapcpp2_yacc.c | sed -e s/cc$/hh/ -e s/cpp$/
    hpp/ -e s/cxx$/hxx/ -e s/c++$/h++/ -e s/c$/h/` y.output soapcpp2_yacc.output -- yacc -d -v
    ../../ylwrap: line 176: yacc: command not found
    
  • A little weird because I think it's part of Scientific Linux core.
  • Do you have 'yacc' on your system?
    • If not, do you have 'bison'?
    • If you do, try
      alias yacc='bison'
      and run the
      third_party/bash/46gsoap.bash  and third_party/bash/47cdb_cpp.bash
      installers -- in that order -- and then scons again
    • You can also get yacc installed on your system
      yum whatprovides /usr/bin/yacc
      ....<snipped>....
      byacc-1.9.20070509-7.el6.x86_64 : Berkeley Yacc, a parser generator
      Repo        : slf
      Matched from:
      Filename    : /usr/bin/yacc
      
      byacc-1.9.20070509-7.el6.x86_64 : Berkeley Yacc, a parser generator
      Repo        : installed
      Matched from:
      Other       : Provides-match: /usr/bin/yacc
      
#2

Updated by Greis, Jan over 4 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Brilliant, thanks! Turns out neither yacc nor bison were installed on the computing nodes of the Warwick cluster (they were installed on the head node...)
I asked to have them installed and now it installs without problem.

Also available in: Atom PDF