Project

General

Profile

Bug #1868

Cpp Reducers do not work with OutputCppRoot

Added by Dobbs, Adam about 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Code Infrastructure
Target version:
Start date:
06 September 2016
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

Whenever MAUS is run with both a cpp reducer and OutputCppRoot a seg fault occurs. This is not critical, but it is certainly not desirable behaviour. Typical stack trace:

#5  0x00007f74afe1d9aa in MAUS::Spill::GetRunNumber (this=0x0) at src/common_cpp/DataStructure/Spill.cc:209
#6  0x00007f7497a8cdfb in MAUS::OutputCppRoot::run_number<MAUS::Data> (this=0x42d8440, data_cpp=0x107e1950) at src/output/OutputCppRoot/OutputCppRoot.cc:266
#7  0x00007f7497a9aacb in MAUS::OutputCppRoot::check_file_exists<MAUS::Data> (this=0x42d8440, data_cpp=0x107e1950) at src/output/OutputCppRoot/OutputCppRoot.cc:231
#8  0x00007f7497a96fbd in MAUS::OutputCppRoot::write_event<MAUS::Data> (this=0x42d8440, py_data=0x3725780) at src/output/OutputCppRoot/OutputCppRoot.cc:140
#9  0x00007f7497a8c857 in MAUS::OutputCppRoot::_save (this=0x42d8440, py_data=0x3725780) at src/output/OutputCppRoot/OutputCppRoot.cc:184
#10 0x00007f7497a8b506 in MAUS::OutputBase::save_pyobj (this=0x42d8440, data_in=0x3725780) at ./src/common_cpp/API/OutputBase-inl.hh:35
#11 0x00007f7497a9e600 in MAUS::PyWrapOutputBase<MAUS::OutputCppRoot>::save (self=0x30edf90, args=0x4b00b90, kwds=0x0) at ./src/common_cpp/API/PyWrapOutputBase-inl.hh:98
#1

Updated by Dobbs, Adam over 4 years ago

  • Status changed from Open to Rejected

They are not meant to by design - closing.

Also available in: Atom PDF