Project

General

Profile

Bug #1856

InputCppRootData overflows the ref counter

Added by Dobbs, Adam over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Code Infrastructure
Target version:
Start date:
13 June 2016
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

The module InputCppRootData can cause an error due to an overflow in the maximum number of reference counts if it is used to import a data file of significant size. Output:

TRANSFORM/MERGE/OUTPUT:  Processed 97 events so far, 1 events in buffer.
terminate called after throwing an instance of 'MAUS::Exception'
  what():  Too many data references at Data::IncreaseRefCount
Aborted

This arises from the IncreaseRefCount method of the Data datastructure class. Looks like a buffer needs flushing somewhere.


Files

2016-06-29_Iss1856-InputCppRootData.tar.gz (68.8 KB) 2016-06-29_Iss1856-InputCppRootData.tar.gz Rogers, Chris, 29 June 2016 11:09
TSRefBugScripts.tar.gz (1.99 KB) TSRefBugScripts.tar.gz Greis, Jan, 30 June 2016 10:25

Related issues

Related to MAUS - Bug #1858: InputCppRootData use can lead to an error from TRefArray about the process IDClosedDobbs, Adam22 June 2016

Actions
#1

Updated by Rogers, Chris about 5 years ago

I could not reproduce the bug. I attempted to load 1000 spills successfully. Download attached tarball, untar then do

bash run.bash

Any clues?

#2

Updated by Rogers, Chris about 5 years ago

I am waiting for a response - I can't reproduce the bug, so can't fix it! A little help please?

#3

Updated by Greis, Jan about 5 years ago

Hi Chris, sorry, somehow didn't receive an email notification from post #1.
I've attached a set of scripts that reproduce the error. Adjust the paths, then run dstest.sh

#4

Updated by Rogers, Chris about 5 years ago

This gives me the TRefArray bug #1858 but not this one...

#5

Updated by Greis, Jan about 5 years ago

Oh, I do apologize, I mixed up issues there. Yes, this is #1858, I personally haven't seen this one.

#6

Updated by Rogers, Chris about 5 years ago

Great. I will reject this one unless someone can demonstrate the problem...

#7

Updated by Dobbs, Adam about 5 years ago

I found this issue while investigating #1858, hang on let me see if I can whip something up to reproduce...

#8

Updated by Dobbs, Adam about 5 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

OK, I have not been able to reproduce yet (spiteful things computers). I will close, and resurrect if need be... thanks Chris.

Also available in: Atom PDF