Project

General

Profile

Bug #1815

MAUS numpy fails on GRID

Added by Rajaram, Durga over 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
01 February 2016
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

Janusz reports that MAUS installations are failing to run on GRID nodes.

After digging, found that the problem is coming from numpy/linalg

The diagnosis:
numpy gets built with system atlas/lapack libraries if they're available.
This causes a problem when porting the MAUS libraries to the GRID because the system lapack library is no longer available on the worker node thereby causing numpy import to fail.

The numpy installer script should force the installation to build standalone numpy/linalg/lapack_lite.so [ as it is done when there is no system-wide atlas/lapack ]

Also available in: Atom PDF