Project

General

Profile

Feature #1810

Carrying field maps with the CDB geometry

Added by Bayes, Ryan about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Geometry
Target version:
Start date:
22 January 2016
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

There is a request to include field maps for the solenoids with the CDB geometry.

Requires
  • ensuring that the "Symmetric Solenoid" field type is supported by the Parent File creation.
  • ensuring that the field map can be uploaded and downloaded dependably.

Files

bfield_vs_z.png (6.37 KB) bfield_vs_z.png Bayes, Ryan, 29 January 2016 09:41
#1

Updated by Bayes, Ryan about 5 years ago

I have made the necessary changes to the "ParentFileCreation.xsl", "GDMLtoCDB.py", and "GDMLFormatter.py" files to allow the field map to be uploaded and downloaded to and from CDB. I have produced a preproduction geometry (710) with the field map included so I can test the download. The download works, I just need to make sure that the field is supported in my test branch. However I have a question.

  • Do we want to be able to scale the magnetic field and is such scaling valid? The example given by Fran├žois did not include scaling. Furthermore the point of the magnetic field is to correct for the effect of the yoke which is very non-linear.
#2

Updated by Bayes, Ryan about 5 years ago

The changes have been successfully applied and has passed all tests. I am going out on a limb and I will not impose a scale factor for the time being ... although I have written the style sheet, it has been commented out. I pushed the changes to a new branch and proposed it for a merge to the trunk.

#3

Updated by Bayes, Ryan about 5 years ago

Here is the magnetic field magnitude resulting from an opera field map uploaded to the preproduction CDB and downloaded prior to use with the default simulation. The field map defines the upstream end coil and centre coil fields while all other magnetic fields are defined using the default currents in the geometry. This shows that the opera field map produces a 4 tesla field that is similar, but not identical to the default magnetic field, as one would expect because the opera field map includes effects from the steel yoke.

Comments about the use case as it stands now:

1. The field map uses a static scaling of 1 because it is not clear to me how the field would scale with current.
2. The field is a property of the geometry its self dictated by the field descriptions in the MAUS_Information file of the geometry upload. To use this field for the simulation of the October SSU field on runs we can upload the geometry so that this geometry will appear for the runs of interest, and then it is a simple matter of downloading the geometry by run number. Alternatively (if we feel we are in a debugging mode) the geometry with the opera field map can be uploaded with a future date and the download can be done by geometry ID with the beam line and cooling channel currents downloaded for the specific runs in question (there is the facility for that mode of operation). Most likely the first option will be pursued.

#4

Updated by Rajaram, Durga about 5 years ago

Comments about the use case as it stands now:

1. The field map uses a static scaling of 1 because it is not clear to me how the field would scale with current.

This is fine.

2. The field is a property of the geometry its self dictated by the field descriptions in the MAUS_Information file of the geometry upload. To use this field for the simulation of the October SSU field on runs we can upload the geometry so that this geometry will appear for the runs of interest, and then it is a simple matter of downloading the geometry by run number.

This is fine.

Is this now ready to be merged into MAUS?

#5

Updated by Bayes, Ryan about 5 years ago

I believe that this is ready to be merged.

#6

Updated by Bayes, Ryan about 5 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This has been merged

#7

Updated by Dobbs, Adam about 5 years ago

  • Target version changed from 70 to Future MAUS release

Also available in: Atom PDF