Project

General

Profile

Bug #1777

Bug in constant_solenoid beam with angular momentum

Added by Rogers, Chris almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Simulation
Target version:
Start date:
16 October 2015
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

By email, from Ao, confirmed by Rogers...

As I was going through a way to do tracking in G4BL, I also read your
code: build/beam.py

I noticed in __birth_transverse_ellipse, for the constant_solenoid mode,
there was:

beta_4d = (1.+beam_def['normalised_angular_momentum'])**0.5/k_s

​while from Kenn's note 71, it should be

beta_4d = (1.+beam_def['normalised_angular_momentum']***2*)**0.5/k_s​
​?

Was it because when you define the data card, you want people to include
that factor?

#1

Updated by Liu, Ao almost 6 years ago

beta_4d = (1.+beam_def['normalised_angular_momentum']**2)**0.5/k_s​

Previous post had too many *

#2

Updated by Rogers, Chris almost 6 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Closed in r963

Also available in: Atom PDF