Project

General

Profile

Feature #1666

Remaining geometry integration issues

Added by Bayes, Ryan over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Geometry
Target version:
-
Start date:
07 April 2015
Due date:
14 April 2015
% Done:

100%

Estimated time:
8.00 h
Workflow:
New Issue

Description

There are a handful of issues related to the geometry that need to be concluded.

  • Inclusion of the cooling channel information in the geometry download --- this exists but has been disabled because there has been no superconducting magnet information in any CDB record to date (except for tags)
  • Allow the geometry to be downloaded with tagged beam line/cooling channel information. This should allow the simulation some ability to pre-date data collection.
  • Upload G4beamline files with the geometry. This should be as "easy" as allowing *.txt files in the tar file build during the geometry upload. Right now it only allows ".gdml" and ".xml" files.
  • Produce a fit for the rotation of quad fields. Some of the quads appear to be misaligned in the CAD output. This should generate a rotation in space for the field (under the assumption that the iron in the quad defines the rotation/position of the field).

All of these (except the last point) should be "trivial" changes. The last can use existing fitting algorithms developed for the survey fits, so it should not require anything particularly new.

#1

Updated by Bayes, Ryan over 7 years ago

To review the points raised in the above issue.

  • the cooling channel information is not as simple to add as I thought. The cooling channel information is parsed from xml to a python dictionary formatted string. It would be much better to have the capacity to download the xml explicitly.
  • the tagged beam line information is also parsed with no python data member (on the production data base) that returns the preferred xml format. This is true for both the beam line and the cooling channel api classes. A function can be written to turn the parsed string back to an xml format can be written, but this seem unnecessary.
  • A recursive extension to the geometry upload algorithm has been written to preserve the G4beamline deck structure. It also allows ".txt" files for This has yet to be tested.
  • I am no longer sure about the fit for the quad field orientation; what is the physical meaning of such a fit and it may be complicated by the orientation of the physical elements (which is not obvious from the GDML) in addition to the position of the quad elements (which is easy to extract). For this reason, I will set this aside for the time being. The field positions are still based on the position of the contributing quadrupole elements.
#2

Updated by Bayes, Ryan over 7 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100
To conclude.
  • I have written a small function to translate the cooling channel information into a python dictionary. This was done under the assumption that the cooling channel information will be required sooner rather than later when the CDB allows cooling channel downloads in an xml format. I have also introduced an option to read the cooling channel information from a different cdb server than the geometry (for example geometry from the production server and cooling channel information from the preproduction server)
  • Accessing tagged beam line information is now moot due to the beam tuning exercises on the weekend of April 25-26. That said the function now exists to access the tagged beam line information with the same sort of method as used for the cooling channel information. I have also introduced an option to download a specific beam line configuration with an arbitrary geometry id so a step IV geometry can be used with beam line settings from a Step I run.
  • The upload for the G4beamline decks is now complete and tested with an upload to the preproduction data base (which means I could not check the download at this time). The file list contains the data structure of the G4beamline deck in addition to the GDML files so I took that to mean that the upload works as required. The next test (barring correction of the geometry download problem on the preproduction data base) is to copy the upload scripts to miceonrec01 and test this capability with a production geometry. A new production geometry will go up in the near future with the introduction of the GDML parser to a MAUS release.
  • The quad field fit was rejected as an improvement to make at this time.

The above changes have passed the MAUS tests and they are ready to be merged with the maus trunk.

Also available in: Atom PDF