Project

General

Profile

Feature #1633

Set unpacking version through environment

Added by Rajaram, Durga over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
05 March 2015
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

With the change to the DATE libraries, MAUS will need to set the unpacker version to link against.
53unpacking.bash will build both StepI and StepIV libraries.
An environment variable should then:
  • set the unpacking library to link against -- either libMDUnpack_StepI.so or libMDUnpack_StepIV.so
  • set a compiler flag -D_STEPIV_DATA to pick up the correct header IF StepIV
  • NOT build InputCppDAQOnlineData IF StepI

Also available in: Atom PDF