Project

General

Profile

Bug #1614

Test fail on SL64 - test_geometry_validation

Added by Rogers, Chris over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Testing
Target version:
Start date:
26 January 2015
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I had a brief look at this - it is almost certainly a memory size issue. The test that is failing is at:

tests/integration/test_utilities/test_geometry_validation/test_geometry_validation.py

The memory usage is high because the test job runs over a 15 m long beamline with 5 mm step size in r, z and stores everything in memory. That is 150,000 steps, each of which is probably one or two hundred bytes or so in memory. I will fix it in a bit.


Related issues

Is duplicate of MAUS - Bug #1642: Tests failing due to out of memory error in test_latest_geometry.pyClosedRogers, Chris13 March 2015

Actions
#1

Updated by Rogers, Chris about 6 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Looks like this is okay for now...

Also available in: Atom PDF