Project

General

Profile

Feature #1511

SciFi data processing verbosity in new API

Added by Dobbs, Adam about 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tracker
Target version:
Start date:
01 July 2014
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

In the trunk SciFi currently outputs a large amount of spam when being processed by the new API:

...
OBJ: MAUS::SciFiCluster MAUS::SciFiCluster       : 0 at: 0x16f0c950                         
OBJ: MAUS::SciFiCluster MAUS::SciFiCluster       : 0 at: 0x169ba440                         
OBJ: MAUS::SciFiCluster MAUS::SciFiCluster       : 0 at: 0x16f0d2a0                         
OBJ: MAUS::SciFiCluster MAUS::SciFiCluster       : 0 at: 0x169d6800                         
OBJ: MAUS::SciFiCluster MAUS::SciFiCluster       : 0 at: 0x16f0cfb0                         
OBJ: MAUS::SciFiCluster MAUS::SciFiCluster       : 0 at: 0x158a9900   
... 

Chris, could you zap wherever the cout / cerr is please? Thanks.

#1

Updated by Rogers, Chris about 7 years ago

I believe this is caused by

src/common_cpp/JsonCppProcessors/Common/ReferenceResolverJsonToCpp-inl.hh:136:  data_address->ls();

Could you delete it and see if that fixes the issue? (Blame Ian)

#2

Updated by Dobbs, Adam about 7 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Thanks, that did it. Will push to the trunk.

Also available in: Atom PDF