Project

General

Profile

Bug #1462

Cannot build merge branch

Added by Dobbs, Adam over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
07 May 2014
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I am currently unable to build the merge branch of maus. Log file attached. Seems to be failing to find freetype, which I do have on my system...


Files

install.log (5.33 MB) install.log Dobbs, Adam, 07 May 2014 15:53
install.log (9.04 MB) install.log Dobbs, Adam, 07 May 2014 17:25
install.log (9.33 MB) install.log Dobbs, Adam, 07 May 2014 21:39
install.log (9.8 MB) install.log Dobbs, Adam, 08 May 2014 14:17
#1

Updated by Dobbs, Adam over 7 years ago

  • Category set to Build System
  • Assignee set to Rogers, Chris
  • Target version set to Future MAUS release
#2

Updated by Dobbs, Adam over 7 years ago

Update: Have got it to build on an Imperial machine running CentOS (cf the other which was on Ubuntu), though it failed the tests, log attached again.

#3

Updated by Dobbs, Adam over 7 years ago

Strike that, was for an out of date version of the branch, rebuilding...

#4

Updated by Dobbs, Adam over 7 years ago

OK, still building on the Imperial machine, but still failing the full tests, log attached again (apologies for the spam).

#5

Updated by Rajaram, Durga over 7 years ago

I don't see this on my SL6 box.

However, it does seem to be a ROOT issue:
http://root.cern.ch/phpBB3/viewtopic.php?f=3&t=17419

problem seems to be systems where the installed freetype header is in /usr/include/freetype2/
and the compiler looks for it in /usr/include/freetype/

One solution that should work is suggested in one of the posts:

As superuser,

ln -s /usr/include/freetype2 /usr/include/freetype

Can you try that?

Longer term, looks like there may be a patch for it.

Can you also post your OS and processor specs?

#6

Updated by Rajaram, Durga over 7 years ago

The test error in
http://micewww.pp.rl.ac.uk/attachments/2157/install.log

seems unrelated and appears to be because the cdb service is not responding

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /.

Reason: Error reading from remote server

Apache/2.2.3 (Scientific Linux) Server at cdb.mice.rl.ac.uk Port 80
#7

Updated by Rogers, Chris over 7 years ago

CDB has been down since 17.00 yesterday. Sorry about that.

To get around this sort of problem in the past, I made third_party/install/bin/library_finder.py; which trawls through /usr/ and looks for specified lib files, links to them in third_party/install/lib. It's pretty hacky, but this sort of thing always comes up in linux... currently works for lib files (not header files).

#8

Updated by Dobbs, Adam over 7 years ago

OK, making progress. It can now finish compiling the third party libraries on my Ubuntu laptop, but it is now failing when building MAUS (again install log attached). I know Ubuntu is not officially supported, but it is a very useful option to have (at least if you are me!). Also, could someone give the CDB a kick so I can verify my Imperial installation?

#9

Updated by Rogers, Chris over 7 years ago

There is an incorrect throw statement in ConverterFactory-inl.hh which doesn't follow the overloaded function call. for some reason this is only picked up by more recent gcc, which I guess is what Adam has in Ubuntu. I've got to do a merge on something else and then I will fix it.

#10

Updated by Dobbs, Adam over 7 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Fix pushed to merge branch. Closing issue.

#11

Updated by Rajaram, Durga over 7 years ago

  • Target version changed from Future MAUS release to MAUS-v0.8.4

Also available in: Atom PDF