Project

General

Profile

Bug #1435

Test error from trunk

Added by Dobbs, Adam over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Category:
Testing
Target version:
Start date:
19 March 2014
Due date:
% Done:

100%

Estimated time:
Workflow:
Closed

Description

I noticed that I was seeing an error in test_ReduceCppGlobalPID.py in the merge branch recently. I did not manifest itself on the test server however. I have now checked this on different machines however and it persists and is now all part of the latest release. It looks like something trivial to solve but I think it is real even if it only shows up on some machines. See the attached for details.


Files

TestErrors.txt (3.13 KB) TestErrors.txt Dobbs, Adam, 19 March 2014 14:36
#1

Updated by Rajaram, Durga over 7 years ago

Interesting, Adam.

Does the directory

/vols/mice3/adobbs/maus/tracker_devel/files/PID/test_200MeV_pi_plus_2014_03_19T14_29_05_882157
actually exist?

If it does, are you able to remove it by hand with rm -rf ?

#2

Updated by Dobbs, Adam over 7 years ago

More interesting the more I look at it. The directories do exist, but are empty after the test terminates. I have tried removing them from the command line and then re-running the test, but the same error crops up. As far as I can tell the right command to remove a directory tree in python is being used by the test (shutil.rmtree) and when I tried to remove one of those directories by hand in python, it did it without problem.

Note: I see the same thing running on both the Imperial HEP machines running CentOS, and the RAL PPD cluster, both using a clean version of MAUS-v0.8.3 (I think I tried it on my Ubuntu laptop too...)

#3

Updated by Rajaram, Durga over 7 years ago

What are the file permissions for the directory(ies) that are left hanging around?

I have pushed a fix to lp:~durga/maus/1435
asking it to forcibly remove the directory with rm -rf

        #shutil.rmtree(PDFdirectory)
        os.system('rm -rf %s' % PDFdirectory)

I can't reproduce the error here, so can you try it and let me know if the fix resolves the problem?

#4

Updated by Heidt, Christopher over 7 years ago

I just ran the tests and received this exact same set of errors, building from the tracker development branch on one of the Imperial machines.

#5

Updated by Dobbs, Adam over 7 years ago

  • Workflow changed from New Issue to Awaiting Merge

Hi Durga, yes that fix seems to have solved it now. Thanks very much.

#6

Updated by Rajaram, Durga over 7 years ago

  • Workflow changed from Awaiting Merge to Closed

Pushed to trunk.

#7

Updated by Rajaram, Durga over 7 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100
#8

Updated by Rajaram, Durga over 7 years ago

  • Target version changed from Future MAUS release to MAUS-v0.8.4

Also available in: Atom PDF