Project

General

Profile

Bug #1394

SciFi track points with tracker=0 and station=0 showing up in simulation data

Added by Lane, Peter over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Tracker
Target version:
Start date:
04 January 2014
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I found this trying to extract space points for global reconstruction. I add my mapper (MapCppGlobalRawTracks) to the simulate_mice workflow. Here's the condensed code snipet:

void MapCppGlobalRawTracks::LoadSciFiTracks(
MAUS::ReconEvent const * const recon_event,
GlobalDS::TrackPArray & tracks) {
...
SciFiEvent const * const scifi_event = recon_event->GetSciFiEvent();
SciFiTrackPArray scifi_tracks = scifi_event->scifitracks();
...
SciFiTrackPArray::const_iterator scifi_track = scifi_tracks.begin();
for (; scifi_track != scifi_tracks.end(); ++scifi_track) {
SciFiTrackPointPArray scifi_track_points = (*scifi_track)->scifitrackpoints();
SciFiTrackPointPArray::const_iterator scifi_track_point = scifi_track_points.begin();
for (; scifi_track_point != scifi_track_points.end(); ++scifi_track_point) {
const int tracker = (*scifi_track_point)->tracker();
const int station = (*scifi_track_point)->station();
std::cout << "DEBUG MapCppGlobalRawTracks::LoadSciFiTrack: " << std::endl
<< "\tTracker: " << tracker << "\tStation: " << station << std::endl;
...

In my output I get

DEBUG MapCppGlobalRawTracks::LoadSciFiTrack:
Tracker: 0 Station: 0

The problem is that stations are numbered from 1-5 in the geometry, and track points are showing up with station = 5 as well.

#1

Updated by Lane, Peter over 7 years ago

Ed, you said you thought you knew where this was coming from, but just in case it's useful here is one set of track point coordinates with associated station numbers:

Tracker: 0      Station: 0                                              
r=(0.511169, 6.03854) P=(-2.1319, 4.06478, 151.282)
Tracker: 0      Station: 0                                              
r=(0.520327, 6.02074) P=(-2.11279, 4.13329, 151.243)
Tracker: 0      Station: 1                                              
r=(0.529492, 6.00294) P=(-2.10329, 4.1372, 151.211)
Tracker: 0      Station: 1                                              
r=(-1.011750499, 1.792503006) P=(3.485884658, 1.496008066, 151.1814965)
Tracker: 0      Station: 1                                              
r=(-1.026919964, 1.789774357) P=(3.518688641, 1.383206526, 151.1427053)
Tracker: 0      Station: 2                                              
r=(-1.042299758, 1.784458853) P=(3.566248403, 1.222322625, 151.1038537)
Tracker: 0      Station: 2
r=(-4.9895437, 5.133197676) P=(-0.3647312988, -3.865809299, 151.0649994)
Tracker: 0      Station: 2
r=(-4.987759647, 5.149962981) P=(-0.4229902914, -3.880697976, 151.0261368)
Tracker: 0      Station: 3
r=(-4.985729905, 5.166794612) P=(-0.4797948238, -3.894879932, 150.9872682)
Tracker: 0      Station: 3
r=(0.9712921812, 6.936044493) P=(-2.458938129, 3.019648308, 150.9483939)
Tracker: 0      Station: 3
r=(0.9815640334, 6.923143004) P=(-2.368604141, 2.991196877, 150.9095129)
Tracker: 0      Station: 4
r=(0.9914426061, 6.910363067) P=(-2.277097515, 2.961955905, 150.870625)
Tracker: 0      Station: 4
r=(-2.992090178, 2.553763384) P=(3.195855224, -1.991572972, 150.8317316)
Tracker: 0      Station: 4
r=(-3.005888439, 2.562413447) P=(3.184601039, -2.007854867, 150.7928305)
Tracker: 0      Station: 5
r=(-3.019641586, 2.57113512) P=(3.173308466, -2.023862135, 150.7539209)
#2

Updated by Santos, Edward almost 7 years ago

This has been solved in some revision prior to 1128 of tracker_devel.

#3

Updated by Hunt, Christopher over 6 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF