Project

General

Profile

Bug #1386

SciFi Cluster Reconstruction showing anomalous results

Added by Dobbs, Adam almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Category:
Tracker
Target version:
Start date:
05 December 2013
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

I have been looking at momentum outliers from pattern recognition. Part of the issue present seems to stem from very low momentum clusters being accepted as part of spacepoints. See the attached for an example (px_mc_1 is the momentum from the first cluster of the seed spacepoint, and so). Here we can clearly see a low momentum cluster present, the first cluster in the second spacepoint of the first track.

The subsequent spacepoints however do tend to still fit tracks well. This output was generated without the scifi noise mapper, so that should not be the cause (after checking with Chris Heidt). Ed, could you investigate please? Thanks.


Files

bad_cluster.txt (2.15 KB) bad_cluster.txt Dobbs, Adam, 05 December 2013 15:21
#1

Updated by Santos, Edward almost 8 years ago

Is production of secondaries on? That's what it looks like.

#2

Updated by Dobbs, Adam almost 8 years ago

It is yes. The trouble is that if they are from secondaries, the cluster / spacepoint rec is mixing in them in with the those from muons.

#3

Updated by Santos, Edward almost 8 years ago

That cluster is likely to have been produced by muon and electron hits in the fibre. It just happened that an electron digit was used to keep the mc position and momentum values.

If it was produced by electron hits only... then it's a noisy cluster we can't remove - the odds for this happening are very(!) low. The condition for making 3-cluster spacepoints is already very strict.

#4

Updated by Dobbs, Adam almost 8 years ago

Good, so it sounds like it probably isn't an issue then. Chris H, this sounds like something we could use your mc lookup code to check perhaps?

#5

Updated by Heidt, Christopher almost 8 years ago

Its possible, the problem that comes to mind is that I don't think we can differentiate between secondary electrons and beam electrons (or any other particle) without putting in some sort of momentum cut. I can certainly add particle information to mclookup though.

#6

Updated by Dobbs, Adam almost 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hmmm, ok I am going to close this issue as it stands, and when we have the hits to digits look up fully up and running, the spacepoint efficiency analysis using it should show if there is any issue or not (my bet being not).

Also available in: Atom PDF