Project

General

Profile

Bug #1249

building MAUS-v0.5.0 - fails to find jsoncpp

Added by Kyberd, Paul over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
11 April 2013
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

ERROR: Couldn't find jsoncpp.
scons: Reading SConscript files ...
Checking whether the C++ compiler worksyes
Checking for C++ library json... no
ERROR: Couldn't find jsoncpp.
FAIL! See logs.x

build on FEDORA 17
I have done a yum install jsoncpp - which succeeded.
I think this error has occurred before but I can't see
a reference in the issues


Files

install.log (2.79 MB) install.log Kyberd, Paul, 11 April 2013 16:10

Related issues

Related to MAUS - Bug #1262: Error while installing Maus0.5.1ClosedRogers, Chris26 April 2013

Actions
#1

Updated by Kyberd, Paul over 9 years ago

doing a find -- shows the files appear to be in the third_party tree nad
none of them are empty

./home/paul/research/mausV5/third_party/bash/52jsoncpp.bash
./home/paul/research/mausV5/third_party/source/jsoncpp-src-0.5.0.tar.gz.md5
./home/paul/research/mausV5/third_party/source/jsoncpp-src-0.5.0.tar.gz
./var/lib/yum/yumdb/j/899778f4891cae822e8d5a3eb315b022fef27c27-jsoncpp-0.6.0-0.9.rc2.fc17-x86_64
find: `./run/user/paul/gvfs': Permission denied
./usr/lib64/libjsoncpp.so.0
./usr/lib64/libjsoncpp.so.0.0.0
./usr/share/doc/jsoncpp-0.6.0

#2

Updated by Rogers, Chris over 9 years ago

The problem is that ROOT install fails on Fedora:

In file included from include/TTF.h:30:0,
                 from /home/paul/research/mausV5/third_party/build/root_v5.30.03/graf2d/graf/src/TTF.cxx:23:
/usr/include/ft2build.h:56:38: fatal error: freetype/config/ftheader.h: No such file or directory
compilation terminated.
make: *** [graf2d/graf/src/TTF.o] Error 1
FAIL: Failed to configure/make

You need to do a manual root install (follow the script third_party/bash/21root.bash if you like).

#3

Updated by Rogers, Chris over 9 years ago

Should say this is a known issue - we need to update ROOT version

#4

Updated by Taylor, Ian over 9 years ago

A general, but hopefully helpful, comment for those that are seeing errors such as this, where an external dependency is missing.

On Redhat based machines (including Fedora), the rpm package that would provide the missing file can be determined by running:

yum provides */<missing_file_name>

This package can then be installed with:

yum install <package_name>

although this will obviously require root access or sudo privileges.

For apt users (Debian, Ubuntu), an equivalent command would be:

apt-file search <missing_file_name>

but you'll first have to install the apt-file tool:

apt-get install apt-file

Hope this is helpful,

Ian

#5

Updated by Rogers, Chris over 9 years ago

  • Category set to Build System
  • Status changed from Open to Closed
  • Assignee set to Rogers, Chris
  • Target version set to Future MAUS release
  • % Done changed from 0 to 100

I think this is done (a workaround was proposed for build on Fedora 17). Long term fix we will upgrade ROOT version... sometime... when we get around to it...

#6

Updated by Kyberd, Paul over 9 years ago

Work round failed ... so issue is still unresolved.
I went back to centos, but because this tends to be a bit slow on release it
is not ideal for new laptops. Scientific Linux the other supported release
also tends to have issues running on virtual machines.

#7

Updated by Rogers, Chris over 9 years ago

  • Status changed from Closed to Open
  • % Done changed from 100 to 0

Well, I don't know quite what we can do - if your linux distribution does not work with ROOT then I don't quite know how to progress.

#8

Updated by Taylor, Ian over 9 years ago

Sorry, I was tryign to help Paul with this, but I became distracted with MOM duties.

I have successfully installed all MAUS software on Fedora 17 and 18, so I know that this is do-able.

To make life easier, we can aim to do two things:

a) move to a new ROOT. As Chris said, this is in the works, and will happen in it's own time.

b) provide a list of dependencies. This can be as simple as:

freetype/config/ftheader.h
iostream
etc...

and we provide some simple instructions for determining which packages are needed, depending on whether you are running a yum or apt based distro. This list can be compiled organically as we go along, when someone has an issue with a dependency being missing, they add it to the wiki, as well as solving their own problem.

#9

Updated by Kyberd, Paul over 9 years ago

Ian's comments were useful and allowed me to make progress, but in the end did not solve the problem. I ran out of ideas (and time) so I retreated to something which worked. The fact that Ian is MOM means that he has other things to do than sort out problem with an unsupported version of Linux. I posted the response because of what I see as a real problem for people trying to get a version running locally. There are two versions of linux supported and there are good reasons for choosing those versions. But neither of them are the most reliable in terms of installation on a random piece of hardware. Not sure there is a solution to the problem, but I wanted to point out that I felt it was a problem.

#10

Updated by Rogers, Chris over 9 years ago

Can I close this issue? I think it is fixed with the new ROOT version which was in 0.5.3.

#11

Updated by Taylor, Ian over 9 years ago

Yes, this can be closed. I had no problem building v0.5.3 on Fedora 18. A list of file dependencies can be compiled at some point, but isn't necessary.

#12

Updated by Rogers, Chris over 9 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Thanks.

Feel free to amend the Install documentation.

#13

Updated by Kyberd, Paul over 9 years ago

I haven't had time to try with Fedora 18, but close it and I'll reopen if required

#14

Updated by Rajaram, Durga over 9 years ago

  • Target version changed from Future MAUS release to MAUS-v0.5.5

Also available in: Atom PDF