Project

General

Profile

Bug #1242

build failed for MAUS-v0.5.0

Added by Santos, Edward over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
21 March 2013
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

Problem with the installation of numpy and json?


Files

install.log (1.2 MB) install.log Santos, Edward, 21 March 2013 12:26
numpy-install_1_5.log (6.84 KB) numpy-install_1_5.log Santos, Edward, 22 March 2013 16:57
#1

Updated by Rogers, Chris over 8 years ago

  • Category set to Build System
  • Assignee set to Rogers, Chris
  • Target version set to Future MAUS release

Note that this is 0.5.0, yesterday's release was 0.5.1. I see I made a typo in the announcement email, let me correct that.

It looks like the numpy install is failing.

FATAL: Failed to install python module numpy

This is using the new pre-packed numpy source. Presumably this is occurring on the Imperial server? Looks like it is failing with the command

from commands import getstatusoutput

I wonder if you could run that command and let me know what the output is? Looks like the python build went okay, so not sure why it is tripping up here. Commands module is

http://docs.python.org/2/library/commands.html

The only thing I wonder if you are picking up some python version 3 by mistake installed elsewhere?

#2

Updated by Santos, Edward over 8 years ago

Ok, the Python installation seems to be ok. After sourcing env.sh, I get a different version of Python that the default in my system:

Python 2.7.2 (default, Mar 21 2013, 12:03:37)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-54)] on linux2

But I can't import getstatusoutput:

import commands
from commands import getstatusoutput

Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: cannot import name getstatusoutput

#3

Updated by Rogers, Chris over 8 years ago

What happens if you do

source env.sh
easy_install numpy >& numpy-install.log
#4

Updated by Santos, Edward over 8 years ago

And that's a Bingo! Output below. Seems to be a permission problem.


Searching for numpy
Reading http://pypi.python.org/simple/numpy/
Reading http://numpy.scipy.org
Reading http://sourceforge.net/project/showfiles.php?group_id=1369&package_id=175103
Reading http://www.numpy.org
Reading http://sourceforge.net/projects/numpy/files/NumPy/
Reading http://numeric.scipy.org
Best match: numpy 1.7.0
Downloading http://pypi.python.org/packages/source/n/numpy/numpy-1.7.0.zip#md5=ca27913c59393940e880fab420f985b4
Processing numpy-1.7.0.zip
Running numpy-1.7.0/setup.py -q bdist_egg --dist-dir /tmp/easy_install-UHtray/numpy-1.7.0/egg-dist-tmp-c6WeeW
Running from numpy source directory.
error: SandboxViolation: open('/dev/null', 'w') {}

The package setup script has attempted to modify files on your system
that are not within the EasyInstall build area, and has been aborted.

This package cannot be safely installed by EasyInstall, and may not
support alternate installation locations even if you run its setup
script by hand. Please inform the package's author and the EasyInstall
maintainers to find out if a fix or workaround is available.

#5

Updated by Rogers, Chris over 8 years ago

What if you try version 1.5?

Something like

easy_install numpy=1.5

#6

Updated by Rogers, Chris over 8 years ago

I mean

easy_install numpy==1.5

Note double equals sign

#7

Updated by Santos, Edward over 8 years ago

Oh, MAUS uses 1.5...

Well, that reproduces the error during the my MAUS installation. I attached the install log.

#8

Updated by Rogers, Chris over 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

By way of documenting - we had a phone chat; we did in the end

import commands
print commands.__file__

Found that commands module was pulling from bzrlib which was in Ed's ${PYTHONPATH}. This conflicted with python commands.py causing the problem. Rogers recommended that Ed instead do easy_install bzr to install bzr along with the rest of MAUS.

I believe this closes the issue - if there is another problem feel free to reopen.

#9

Updated by Rogers, Chris over 8 years ago

  • Target version changed from Future MAUS release to MAUS-v0.5.2

Also available in: Atom PDF