Project

General

Profile

Bug #1239

Root build error Maus0.5

Added by Carlisle, Timothy about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
-
Start date:
12 March 2013
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

=> lib/libPyROOT.so done
bin/rmkdepend R -fio/xmlparser/src/TDOMParser.d -Y -w 1000 - pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -I/data/mice/mice/carlisle/maus/third_party/install/include/libxml2 -D__cplusplus - /data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -I/data/mice/mice/carlisle/maus/third_party/install/include/libxml2 -o io/xmlparser/src/TDOMParser.o -c /data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:29:25: error: libxml/tree.h: No such file or directory
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:30:36: error: libxml/parserInternals.h: No such file or directory
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx: In member function 'virtual Int_t TDOMParser::ParseFile(const char*)':
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:74: error: 'xmlCreateFileParserCtxt' was not declared in this scope
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:83: error: invalid use of undefined type 'struct _xmlParserCtxt'
include/TXMLParser.h:43: error: forward declaration of 'struct _xmlParserCtxt'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:84: error: 'xmlParserGetDirectory' was not declared in this scope
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:85: error: invalid use of undefined type 'struct _xmlParserCtxt'
include/TXMLParser.h:43: error: forward declaration of 'struct _xmlParserCtxt'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:85: error: ISO C++ forbids declaration of 'type name' with no type
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:85: error: ISO C++ forbids declaration of 'type name' with no type
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:85: error: expected primary-expression before 'char'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:85: error: expected `)' before 'char'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:84: warning: unused variable 'dir'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx: In member function 'virtual Int_t TDOMParser::ParseBuffer(const char*, Int_t)':
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:98: error: 'xmlCreateMemoryParserCtxt' was not declared in this scope
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx: In member function 'Int_t TDOMParser::ParseContext()':
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:119: error: 'xmlParseDocument' was not declared in this scope
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:121: error: invalid use of undefined type 'struct _xmlParserCtxt'
include/TXMLParser.h:43: error: forward declaration of 'struct _xmlParserCtxt'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:126: error: invalid use of undefined type 'struct _xmlParserCtxt'
include/TXMLParser.h:43: error: forward declaration of 'struct _xmlParserCtxt'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:131: error: invalid use of undefined type 'struct _xmlParserCtxt'
include/TXMLParser.h:43: error: forward declaration of 'struct _xmlParserCtxt'
/data/mice/mice/carlisle/maus0.5/third_party/build/root_v5.30.03/io/xmlparser/src/TDOMParser.cxx:136: error: invalid use of undefined type 'struct _xmlParserCtxt'
include/TXMLParser.h:43: error: forward declaration of 'struct _xmlParserCtxt'
make: *** [io/xmlparser/src/TDOMParser.o] Error 1
FAIL: Failed to configure/make

the same version of ROOT builds fine in prev. Maus versions. I'll try to source a working copy of root in the meantime.

Thanks,

Tim


Files

install.log (3.37 MB) install.log Carlisle, Timothy, 12 March 2013 11:11
#1

Updated by Rogers, Chris about 9 years ago

  • Description updated (diff)

Do you have an install.log in the directory? Could I see it?

Cheers

#2

Updated by Carlisle, Timothy about 9 years ago

  • Description updated (diff)

there doesn't seem to be one...

#3

Updated by Rogers, Chris about 9 years ago

There should always be an install.log in directory pointed to by $MAUS_ROOT_DIR (environment variable set in env.sh). Did you do the build by running ./install_build_test.bash?

#4

Updated by Carlisle, Timothy about 9 years ago

Sorry, was looking in the wrong directory. Attached!

Thanks

#5

Updated by Rogers, Chris about 9 years ago

What linux are you installing on?

You may need to talk to your linux sysadmin to figure out where libxml is installed on your system (and has it been moved somehow or a system update has removed it?).

#6

Updated by Carlisle, Timothy about 9 years ago

I'm on Scientific Linux release 5.9 (Boron).

Root 5.30.03 appears to build fine with Maus0.4.1 but I'll ask about libxml.

#7

Updated by Rogers, Chris about 9 years ago

Changes in third_party directory since 0.4.1:

removed:
  third_party/source/scons-2.1.0.alpha.20110323.tar.gz.md5
  third_party/source/unpacking-maus.tar.gz
  third_party/source/unpacking-maus.tar.gz.md5
  third_party/source/xboa-0.14.0.tar.gz.md5
added:
  third_party/bash/61monitoring.bash
  third_party/bash/70daq.bash
  third_party/source/SConstruct_unpacking
  third_party/source/daqlib.tgz.md5
  third_party/source/easy_install/
  third_party/source/monitor_test.tar.md5
  third_party/source/xboa-0.15.0.tar.gz.md5
modified:
  third_party/bash/00get_all_libs.bash
  third_party/bash/40python_extras.bash
  third_party/bash/51xboa.bash
  third_party/bash/53unpacking.bash
  third_party/build_all.bash

Some things have moved but nothing that would affect this I think. I changed the order in which some elements were built, in particular moving ROOT to later in the build - but this should not have changed things.

#8

Updated by Carlisle, Timothy about 9 years ago

After reinstalling root (from the tar supplied with 0.5) the build seems to running fine...don't understand why it didn't work when done along with all the third party packages! Will confirm build success when I'm back in the office tomorrow morning.

#9

Updated by Carlisle, Timothy about 9 years ago

ok scrap that, the build still failed.

Just realised the working installation is actually on another machine, forgot about all the softlinks. Will try building 0.5 on that machine & then badger IT to sort out the other one. Will close the issue when build is confirmed!

#10

Updated by Rogers, Chris about 9 years ago

Great to get this sorted. It would be nice to know if we have a missing dependency in our list - so that I can add it.

#11

Updated by Carlisle, Timothy about 9 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Well the fact it works with Maus0.5 in one location implies the libxml install is intact and working, but there's something in Maus build scripts means that the other installation (located on another drive) can't find it.

IT didn't really have a fix, but I've got a working copy I'm happy so will close this thread, unless you have any suggestions..

Also available in: Atom PDF