Project

General

Profile

Bug #1219

Failure to build maus 0.4.2

Added by Kyberd, Paul over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
05 February 2013
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

tried to build the latest version of maus and the log file ends
.....................................

Traceback (most recent call last):
File "setup.py", line 4, in <module>
import cdb
File "/home/paul/research/maus/third_party/build/cdb-0.0.4.0/cdb/__init__.py", line 45, in <module>
from cdb._alarmhandler import AlarmHandler
File "/home/paul/research/maus/third_party/build/cdb-0.0.4.0/cdb/_alarmhandler.py", line 6, in <module>
from cdb._base import CdbBase
File "/home/paul/research/maus/third_party/build/cdb-0.0.4.0/cdb/_base.py", line 12, in <module>
from suds.client import Client
ImportError: No module named suds.client
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "cdb/
_init__.py", line 45, in <module>
from cdb._alarmhandler import AlarmHandler
File "cdb/_alarmhandler.py", line 6, in <module>
from cdb._base import _CdbBase
File "cdb/_base.py", line 12, in <module>
from suds.client import Client
ImportError: No module named suds.client

FATAL: The package failed to build. Review the build output
FATAL: and consider submitting a support request at
FATAL: micewww.pp.rl.ac.uk/projects/maus/issues/

WARNING: MAUS already setup
scons: Reading SConscript files ...
Checking whether the C++ compiler worksyes
Checking for C++ library json... no
ERROR: Couldn't find jsoncpp.
scons: Reading SConscript files ...
Checking whether the C++ compiler worksyes
Checking for C++ library json... no
ERROR: Couldn't find jsoncpp.
FAIL! See logs.x


Files

install_log_std (3.34 MB) install_log_std Kyberd, Paul, 05 February 2013 13:08
suds-0.4-py2.7.egg (437 KB) suds-0.4-py2.7.egg Rogers, Chris, 05 February 2013 17:36
#1

Updated by Rogers, Chris over 8 years ago

Could you attach the build log install_log_std?

Thanks

#3

Updated by Rogers, Chris over 8 years ago

The issue is that "suds" package needed by the config DB client failed to download.

Searching for suds
Reading http://pypi.python.org/simple/suds/
Download error: [Errno -2] Name or service not known -- Some packages may not be found!
Couldn't find index page for 'suds' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
Download error: [Errno -2] Name or service not known -- Some packages may not be found!
No local packages or download links found for suds
Best match: None
Traceback (most recent call last):
  File "/home/paul/research/maus/third_party/install/bin/easy_install", line 8, in <module>
    load_entry_point('setuptools==0.6c11', 'console_scripts', 'easy_install')()
  File "/home/paul/research/maus/third_party/install/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 1712, in main
  File "/home/paul/research/maus/third_party/install/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 1700, in with_ei_usage
  File "/home/paul/research/maus/third_party/install/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 1716, in <lambda>
  File "/home/paul/research/maus/third_party/install/lib/python2.7/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/home/paul/research/maus/third_party/install/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/home/paul/research/maus/third_party/install/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/home/paul/research/maus/third_party/install/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 211, in run
  File "/home/paul/research/maus/third_party/install/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/command/easy_install.py", line 434, in easy_install
  File "/home/paul/research/maus/third_party/install/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/setuptools/package_index.py", line 475, in fetch_distribution
AttributeError: 'NoneType' object has no attribute 'clone'

May be a transient/network error. Try redoing the install.

#4

Updated by Rogers, Chris over 8 years ago

It doesn't work from my machine either... maybe suds has been withdrawn from the package list?

#5

Updated by Rogers, Chris over 8 years ago

  • Category set to Build System
  • Assignee set to Rogers, Chris
  • Target version set to Future MAUS release
#6

Updated by Rogers, Chris over 8 years ago

Please find attached a copy of the suds library suds-0.4.py2.7.egg. To install, download the file to the MAUS root directory and then do

source env.sh
easy_install suds-0.4-py2.7.egg
python -m suds

You should get the last line as

/home/cr67/MAUS/maus_rogers_1219/third_party/install/bin/python: No module named suds.__main__; 'suds' is a package and cannot be directly executed

which means suds is correctly installed. I will remove all dependencies on the python package repository in the next version.

#7

Updated by Rogers, Chris over 8 years ago

Nb: the test server did pass on a full install

http://test.mice.rl.ac.uk/view/Trunk/job/MAUS_full_install/

Maybe a problem with the package repository?

#9

Updated by Rogers, Chris over 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

The python packages now all come down from http://micewww.pp.rl.ac.uk/maus

easy_install was a pain to get working, trying to repack anything always repacks prebuilt binaries (which are platform dependent). So instead I had to just pull down the package using easy_install -b -e option; which means figuring out package dependencies. It was pretty painful!

Anyway, it should be working now. I didn't implement a backup to pull from the easy_install server - so for now we always use micewww. Probably next time there is an outage on micewww I will sort something...

Closed in r902

#10

Updated by Rogers, Chris over 8 years ago

  • Target version changed from Future MAUS release to MAUS-v0.5.0

Also available in: Atom PDF