Project

General

Profile

Support #1204

test failure (MongoDBDocumentStore.py)

Added by Santos, Edward over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Online reconstruction
Target version:
Start date:
12 January 2013
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

tracker_devel is failing to build in Jenkins due to an error arising in src/common_py/docstore/MongoDBDocumentStore.py for which I show the output below.

The test passes in my system (CentOS).

Ideas?

Edward

======================================================================
ERROR: Test connect with a bad host throws an AutoReconnect error as
----------------------------------------------------------------------
Traceback (most recent call last):
File "/home/jenkins/workspace/MAUS_tracker_devel/tests/integration/test_distributed_processing/test_docstore/test_MongoDBDocumentStore.py", line 90, in test_connect_bad_host
self._data_store.connect(parameters)
File "/home/jenkins/workspace/MAUS_tracker_devel/src/common_py/docstore/MongoDBDocumentStore.py", line 59, in connect
parameters["mongodb_port"])
File "build/bdist.linux-x86_64/egg/pymongo/connection.py", line 180, in init
max_pool_size, document_class, tz_aware, _connect, **kwargs)
File "build/bdist.linux-x86_64/egg/pymongo/mongo_client.py", line 274, in init
raise ConnectionFailure(str(e))
ConnectionFailure: could not connect to nonExistant:999999: [Errno -2] Name or service not known

======================================================================
ERROR: Test connect with a bad port throws an AutoReconnect error as
----------------------------------------------------------------------
Traceback (most recent call last):
File "/home/jenkins/workspace/MAUS_tracker_devel/tests/integration/test_distributed_processing/test_docstore/test_MongoDBDocumentStore.py", line 102, in test_connect_bad_port
self._data_store.connect(parameters)
File "/home/jenkins/workspace/MAUS_tracker_devel/src/common_py/docstore/MongoDBDocumentStore.py", line 59, in connect
parameters["mongodb_port"])
File "build/bdist.linux-x86_64/egg/pymongo/connection.py", line 180, in init
max_pool_size, document_class, tz_aware, _connect, **kwargs)
File "build/bdist.linux-x86_64/egg/pymongo/mongo_client.py", line 274, in init
raise ConnectionFailure(str(e))
ConnectionFailure: could not connect to localhost:999999: [Errno 111] Connection refused



Related issues

Is duplicate of MAUS - Bug #1181: PyMongo 2.4 throws ConnectionFailure not Autoreconnect on failed ConnectionClosedRogers, Chris29 November 2012

Actions
#1

Updated by Rogers, Chris over 9 years ago

  • Assignee set to Robinson, Matthew

Matt, could you have a look?

#2

Updated by Rogers, Chris over 9 years ago

  • Category set to Geometry
  • Assignee changed from Robinson, Matthew to Littlefield, Matthew
  • Target version set to Future MAUS release

Apologies, wrong Matthew...

#3

Updated by Dobbs, Adam over 9 years ago

Confirmed, passes for me on the Imperial CentOS cluster, but fails when pushed to Jenkins, even with a clean workspace.

#4

Updated by Rogers, Chris over 9 years ago

  • Category changed from Geometry to Online reconstruction
  • Assignee changed from Littlefield, Matthew to Rogers, Chris

Apologies, I just read this again and realised it wasn't a geometry issue at all. It is in fact duplicate of #1181.

Can you check that you are up to date? Specifically, tests/integration/test_distributed_processing/test_docstore/test_MongoDBDocumentStore.py line 102 should catch a ConnectionFailure not an Autoreconnect.

This should also fail on the Imperial cluster if you reinstall third party libraries...

#5

Updated by Santos, Edward over 9 years ago

You are right. Next push fixes this issue. Thanks!

#6

Updated by Rogers, Chris over 9 years ago

  • Status changed from Open to Rejected

Reject as its a duplicate

Also available in: Atom PDF