Project

General

Profile

Bug #1202

Unable to simulate >40k events

Added by Carlisle, Timothy over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Simulation
Target version:
Start date:
07 January 2013
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

Hi Chris,

I can't simulate with approx. more than 40,000 muon events, getting the error shown below:

(MAUS release version 0.4.1) verbose set to debug.

INPUT: Setting up input
PIPELINE: Get event, TRANSFORM, MERGE, OUTPUT, repeat
HINT: MAUS will process 1 event only at first...
MERGE: Setting up merger
TRANSFORM: Setting up transformer
Written 1 event(s) to file.
Written 1 event(s) to file.
Opening TFile Sim_0mm_1MeVc_50000mu_1e-08nsec_IV_Fe_m1__m0.4.1_MuSc__.root
Opening TFile using existing tree Spill
terminate called after throwing an instance of 'std::bad_alloc'
what(): St9bad_alloc

and no output is given. All the scripts work fine for say 30k events. Any ideas? Cards attached.

Thanks,

Tim


Files

Cards_530.py (1.09 KB) Cards_530.py Carlisle, Timothy, 07 January 2013 14:48
#1

Updated by Rogers, Chris over 8 years ago

  • Priority changed from Normal to Urgent

Ack, sounds bad...

#2

Updated by Rogers, Chris over 8 years ago

  • Priority changed from Urgent to Normal

Sorry for the delay in replying, my brain was stuck in other stuff. So the problem is memory usage I believe. You have 50k particles in a single spill, MAUS buffers data spill-by-spill so it holds all the data for a particular spill in memory at a given time. The problem is that data associated with 50k particles actually have quite a large memory footprint. So you should split the spill up into several smaller spills to make this work... sorry about that.

#3

Updated by Rogers, Chris over 8 years ago

  • Category set to Simulation
  • Target version set to Future MAUS release
#4

Updated by Carlisle, Timothy over 8 years ago

Ahhh ok sorry still have my G4MICE hat on I'm afraid!

#5

Updated by Rogers, Chris over 8 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

No problem - I'll close the issue if thats okay.

#6

Updated by Rogers, Chris over 8 years ago

  • Status changed from Closed to Rejected
  • Target version changed from Future MAUS release to MAUS-v0.4.3
  • % Done changed from 100 to 0

Also available in: Atom PDF