Project

General

Profile

Bug #1157

Online reconstruction fails

Added by Rogers, Chris over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Richards, Alexander
Category:
Online reconstruction
Target version:
Start date:
14 October 2012
Due date:
% Done:

100%

Estimated time:
Workflow:
Under Review

Description

Cross posted to elog...

  • Reported error was that MAUS was making histograms but failing to produce any hits.
  • Assumed some problem with data structure so applied merge with trunk to online code. Still no luck.
  • Made a test_analyze_data_online at tests/integration/test_analyze_online/; hacked that inputter at bin/online/analyze_data_online_input_transform.py so that it uses the offline inputter and bin/analyze_data_online.py so that it specifies a filed number and location. Downloaded data 04168.tar and attempted to reconstruct. No luck, and no daq_data tree at all was created.
  • Tried a different data file; 04010.tar. Still no luck. Prodded InputCppDAQData some - looks like everything is working okay but the line
    _dataProcessManager.Process(_eventPtr);
    didn't seem to fill the "daq_data" branch.
  • Maybe there is something funny about single station tests. Tried 03513 then 03512 data files from March run. 03512 produced daq_data branch but still no histograms - tof reducer complains "No recon_events branch" or similar
  • Added some debugging output into the MapCppTOFDigits and ran input/transform/OutputCppRoot in single threaded mode. MapCppTOFDigits claims that it is indeed producing data...
  • That's as far as I got - I put the code back into multithreaded mode and InputCppOnlineDAQ.
  • So somehow it looks like it is producing reconstruction data but this is getting eaten somewhere...
    Sorry, that's as far as I got. It looks like we will have to do some more debugging next week...

Files

analyze_data_online_input_transform.py (2.89 KB) analyze_data_online_input_transform.py Rajaram, Durga, 16 October 2012 05:46

Also available in: Atom PDF