Project

General

Profile

Bug #1127

Tracker recon not saving data in JSON output.

Added by Heidt, Christopher about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tracker
Target version:
Start date:
06 September 2012
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

Tracker MC is producing mc events and recon events, we can see both mc and recon events in the ROOT output. MAUS, however, is not saving tracker recon events when outputting to JSON format. The tracker mc events are fine in both ROOT and JSON outputs.

#1

Updated by Rogers, Chris about 10 years ago

  • Assignee changed from Long, Kenneth to Dobbs, Adam
  • Target version set to Future MAUS release
#2

Updated by Dobbs, Adam about 10 years ago

I can confirm this. It appears that when running identical simulations, changing only the output module, reconstruction data is seen in ROOT output but not in JSON. This may follow on from a change I made yesterday, where the I moved the SciFiHit data from from being stored in the SciFiEvents in the recon branch, to being stored in the SciFiHits member of the MC events in the MC branch. Should not have made any difference to the output routines, but should and did are not the same. Will need to investigate to see if this is a fault in the SciFi code or in the Processor framework, which should be doing all the i/o for this.

#3

Updated by Rogers, Chris about 10 years ago

What are you doing with my lovely MC data structure?

#4

Updated by Dobbs, Adam about 10 years ago

Solved. The json data was there, just for some reason there were lots of empty events at the start (hmmm). Scrolling down I found plenty of data. To check I converted the json file to ROOT and plotted a parameter, with the mean and # entries matching between the converted and original ROOT files. So, all seems well, closing.

Chris R, nothing at all, I'm putting the SciFiHit data in the existing SciFiHit branch in MC, as the data structure specifies. The move was made to preserve the data structure in fact ;)

#5

Updated by Dobbs, Adam about 10 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100
#6

Updated by Rogers, Chris about 10 years ago

Chris R, nothing at all, I'm putting the SciFiHit data in the existing SciFiHit branch in MC, as the data structure specifies. The move was made to preserve the data structure in fact ;)

Hurrah!

#7

Updated by Heidt, Christopher about 10 years ago

Looks like we tripped up because MCDigitzation is creating a null entry for every real entry. This should be fixed.

#8

Updated by Dobbs, Adam about 10 years ago

Bug found. Turns out the data coming from the MC supplied recon events, which were empty apart from the particle number. I was appending new recon events for the SciFiDigits, rather than appending the SciFi data to the existing recon events. Now fixed.

#9

Updated by Rogers, Chris about 10 years ago

Maybe you don't have the recent enough version - I only added the root stuff in the last few weeks. Should be 0.14.0...

#10

Updated by Rogers, Chris about 10 years ago

  • Target version changed from Future MAUS release to MAUS-v0.3.3

Also available in: Atom PDF