Project

General

Profile

Bug #1095

Potential Load Issue

Added by Littlefield, Matthew about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Simulation
Target version:
Start date:
08 August 2012
Due date:
% Done:

100%

Estimated time:
Workflow:
Awaiting Merge

Description

I've found that trying to run 5000 particles gives an error.

TRANSFORM/MERGE/OUTPUT:  Processed 4 events so far, 1 events in buffer.
Traceback (most recent call last):
  File "/home/matt/maus_littlefield/build/MapPyBeamMaker.py", line 224, in process
    self.bm_fh)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/xboa/Hit.py", line 110, in new_from_read_builtin
    hit.read_builtin_formatted(format, filehandle)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/xboa/Hit.py", line 406, in read_builtin_formatted
    self.__read_formatted(self.__file_formats[format], self.__file_units[format], filehandle)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/xboa/Hit.py", line 703, in __read_formatted
    value = Hit.__default_var_types[key](words.pop())
IndexError: pop from empty list
Traceback (most recent call last):
  File "/home/matt/maus_littlefield/src/common_py/ErrorHandler.py", line 159, in HandleCppException
    raise(CppError(error_message))
ErrorHandler.CppError: Property position  not found in Json object lookup at JsonWrapper::GetPropertyStrict
Traceback (most recent call last):
  File "/home/matt/maus_littlefield/src/common_py/ErrorHandler.py", line 159, in HandleCppException
    raise(CppError(error_message))
ErrorHandler.CppError: std::exception
TRANSFORM/MERGE/OUTPUT:  Processed 5 events so far, 0 events in buffer.

Files

Config.py (3.3 KB) Config.py Configuration File Littlefield, Matthew, 08 August 2012 14:31
handover_mu_only_eng_coords.txt (920 KB) handover_mu_only_eng_coords.txt Particle Data File taken from G4BL Littlefield, Matthew, 08 August 2012 14:31
Rotation.dat (8.49 KB) Rotation.dat Top .dat file Littlefield, Matthew, 08 August 2012 14:31
#1

Updated by Rogers, Chris about 9 years ago

Can you attach the configuration datacards and geometry?

Thanks

#2

Updated by Littlefield, Matthew about 9 years ago

sure

#3

Updated by Rogers, Chris about 9 years ago

Traceback (most recent call last):
  File "/home/matt/maus_littlefield/build/MapPyBeamMaker.py", line 224, in process
    self.bm_fh)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/xboa/Hit.py", line 110, in new_from_read_builtin
    hit.read_builtin_formatted(format, filehandle)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/xboa/Hit.py", line 406, in read_builtin_formatted
    self.__read_formatted(self.__file_formats[format], self.__file_units[format], filehandle)
  File "/home/matt/maus_littlefield/third_party/install/lib/python2.7/site-packages/xboa/Hit.py", line 703, in __read_formatted
    value = Hit.__default_var_types[key](words.pop())
IndexError: pop from empty list

Humm. This could be a malformatted entry in the file. It would be nice if it actually wrote the line where it had a problem though...

I don't think it is a load issue though.

#4

Updated by Rogers, Chris about 9 years ago

By the way these are mu-

#5

Updated by Rogers, Chris about 9 years ago

The problem is that G4beamline format changes halfway through a file

626.955 35.8166 -1049.58 -193.444 -11.9835 320.86 52.2593 13 999734 1 0 1
                                                               ^
                                                     This is an int (particle number)
667.74 466.545 -1026.03 -147.668 25.937 248.978 51.9064 13 1.00017e+06 1 0 1
                                                               ^
                                                     This is a float (particle number)
#6

Updated by Rogers, Chris about 9 years ago

  • Workflow changed from New Issue to Awaiting Merge

I handle now the buggy input from G4Beamline in xboa okay. It may take a few days for me to push a new xboa version however (I would also like to push direct IO of the ROOT VirtualHits/etc)

#7

Updated by Littlefield, Matthew about 9 years ago

OK, will I need to alter my input file or will it be ok after the merge?

#8

Updated by Rogers, Chris about 9 years ago

I don't think I will be able to get a fix in for a week or two. Requires a new version of xboa.

#9

Updated by Rogers, Chris about 9 years ago

But once the fix goes in it will be okay

#10

Updated by Littlefield, Matthew about 9 years ago

OK no problem, Ill fix my file :-)

#11

Updated by Rogers, Chris about 9 years ago

In fact I made a fix in xboa 0.14.0 which is available now from sourceforge. I am updating the 51xboa.bash script in the trunk.

#12

Updated by Rogers, Chris about 9 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This is merged now

#13

Updated by Rogers, Chris almost 9 years ago

  • Target version changed from Future MAUS release to MAUS-v0.3.3

Also available in: Atom PDF