Project

General

Profile

Bug #1056

Problem with Wedge volume

Added by Rogers, Chris over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Simulation
Target version:
Start date:
20 July 2012
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

Looks like the Wedge volume geometry check is failing somehow - looks like it finds a negative number when it should be positive.


Files

stageIVwedge.zip (1.78 KB) stageIVwedge.zip Rogers, Chris, 20 July 2012 09:54
#1

Updated by Rogers, Chris over 9 years ago

Description of issue email from Pavel

Hi Chris,

I've been trying to revive the old g4mice simulation of Step IV with a
wedge. Had some issues with the Boolean volume describing the intersection
of a triangular prism and a cylinder, went back to using a simple wedge
instead of a Boolean volume, and that's where the problem is:

1) Stage4-Wedge.dat is using a Wedge/LiHalfWedge.dat module which
determines the wedge:

=====
Module LiHWedgeHalf
{
  Volume Wedge
  Dimensions 1000 2000 2000.0 mm //x, y, z
  PropertyDouble BlueColour  0.5
}

2) When I run a simulation I get the following output:

=====
Traceback (most recent call last):
  File "/home/snopok/maus/src/common_py/ErrorHandler.py", line 159, in
HandleCppException
    raise(CppError(error_message))
ErrorHandler.CppError: Dimension x in module
Stage4-Wedge.dat/LiWedgeHalf.dat out of range at MiceModToG4Solid::checkDim
Traceback (most recent call last):
  File "./bin/simulate_mice.py", line 54, in <module>
    run()
  File "./bin/simulate_mice.py", line 51, in run
    MAUS.Go(my_input, my_map, MAUS.ReducePyDoNothing(), my_output,
datacards)
  File "/home/snopok/maus/src/common_py/Go.py", line 121, in __init__
    executor.execute()
  File "/home/snopok/maus/src/common_py/framework/single_thread.py", line
65, in execute
    assert(self.transformer.birth(self.json_config_doc) == True)
AssertionError
=====

What is wrong here? The world seems to be large enough to fit this wedge:

=====
Configuration Stage4
{
  Dimensions 1500.0 1000.0 5000.0 cm
  PropertyString Material Galactic
  PropertyDouble G4StepMax 100. mm
  ScaleFactor 1.
  Module Wedge/LiWedgeHalf.dat
  {
    Position 0.0 0.0 0.0 mm // horz wedge
    Rotation 0.0 0.0 0.0 degree // horz wedge
  }
=====

but even if I make the wedge tiny (10. 20. 20. mm) I still get the same
error. With the Boolean volume nothing of a sort happens, but I hoped I
would be able to look at just the wedge. Any ideas?

Pavel

#2

Updated by Rogers, Chris over 9 years ago

  • Status changed from Open to Rejected

Module Wedge/LiWedgeHalf.dat

Should be

  Module Wedge/LiHWedgeHalf.dat
                 ^
               Note typo

Note that MAUS does issue a warning when it fails to load a Module, but it is suppressed in debugging output (set verbose_level 0).

Also available in: Atom PDF