Project

General

Profile

Bug #1050

Error during third-party build

Added by Carlisle, Timothy over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Build System
Target version:
Start date:
18 July 2012
Due date:
% Done:

100%

Estimated time:
Workflow:
New Issue

Description

maus v0.3.0

./build_all.bash
brings up an error at the very end:

g++: graf2d/graf/src/TLatex.o: No such file or directory
make: *** [graf2d/graf/src/TLatex.o] Error 1
FAIL: Failed to configure/make

Thanks for any help, maybe it's me...

Tim

#1

Updated by Rogers, Chris over 9 years ago

  • Category set to Build System
  • Assignee set to Carlisle, Timothy
  • Target version set to Future MAUS release

Maybe it's changed since the last time you ran - could you read the install instructions and try redoing it, let me know if there is still a problem?

http://micewww.pp.rl.ac.uk/projects/maus/wiki/Install

Cheers,

#2

Updated by Carlisle, Timothy over 9 years ago

The problem seems to lie with ROOT v5.30.03. I've downloaded it separately from the Root website, and it won't be build then either - so I've reported a bug.

Tim

#3

Updated by Tunnell, Christopher over 9 years ago

  • Status changed from Open to Rejected
  • Workflow changed from New Issue to Closed

It fails on TLatex.o which appears to get put in the wrong place. Fixing that reveals another issue. It's all the code in the graf2d folder.

Probably a dependency issue but not a MAUS error. I suggested he contact IT support at Oxford.

Tim: if you get the issue again, we can reopen?

#4

Updated by Rogers, Chris over 9 years ago

Which linux?

#5

Updated by Tunnell, Christopher over 9 years ago

  • Status changed from Rejected to Open
  • Workflow changed from Closed to New Issue

SL5. It's called pplxint6. It's the interactive machine at Oxford.

I'll reopen and butt out.

pplxint6:~$ uname -a
Linux pplxint6 2.6.18-274.18.1.el5 #1 SMP Thu Feb 9 12:20:03 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
pplxint6:~$ cat /etc/redhat-release
Scientific Linux SL release 5.7 (Boron)

#6

Updated by Rogers, Chris over 9 years ago

Well, we support SL so if Tim has followed the install instructions and it still won't work this is a bug.

Tim, want to phone?

#7

Updated by Tunnell, Christopher over 9 years ago

But we don't have sudo privileges, so it's probably a dependency problem. ROOT not building on SL5 should probably first be referred to IT support here since it's reproducible and a reasonable request for a particle physics department to be able to install it.

#8

Updated by Carlisle, Timothy over 9 years ago

1) Ok so it turns out ./install_build_tests.bash failed, but I wasn't told...instead it was written to the log! So at the moment there's no output to screen whether the tests failed or not.

this is from the the end of install_log_std:

/////
g++ -O2 -pipe -m64 -Wshadow -Wall -W -Woverloaded-virtual -fPIC -Iinclude -pthread -I/freetype2 -I -o graf2d/graf/src/TLatex.o -c /data/mice/mice/carlisle/maus0.2.5/third_party/build/root_v5.30.03/graf2d/graf/src/TLatex.cxx
g++: graf2d/graf/src/TLatex.o: No such file or directory
make: *** [graf2d/graf/src/TLatex.o] Error 1
FAIL: Failed to configure/make
WARNING: MAUS already setup
./install_build_test.bash: line 76: scons: command not found
./install_build_test.bash: line 80: scons: command not found
FAIL! See logs.x
Your current directory is:
/data/mice/mice/carlisle/maus0.2.5

Your MAUS_ROOT_DIR is:
/data/mice/mice/carlisle/maus0.2.5

These should agree
python: can't open file '/data/mice/mice/carlisle/maus0.2.5/third_party/install/bin/nosetests': [Errno 2] No such file or directory
FAIL! See logs.

Your MAUS_ROOT_DIR is:
/data/mice/mice/carlisle/maus0.2.5

These should agree
python: can't open file '/data/mice/mice/carlisle/maus0.2.5/third_party/install/bin/nosetests': [Errno 2] No such file or directory
FAIL! See logs.

////

2) I'd suggest a change of tense also: run the tests --> ran the tests, otherwise it sounds like the user has to run the tests separately.

#9

Updated by Carlisle, Timothy over 9 years ago

ok I've managed to build the third party libraries, by sourcing a slightly later version of ROOT, and MAUS seems to happy with it. So this issue is effectively closed, though the two points in my previous post still apply I think (particularly point 1)...

Close?

Thanks

#10

Updated by Rogers, Chris over 9 years ago

Yes, in fact the whole messaging system which the bash scripts make is a mistake/wrong...

#11

Updated by Rogers, Chris over 9 years ago

I'm quite unhappy that you need to use a different version of ROOT. What is wrong with the defaults? This should work! Are you sure you put the dependencies in?

#12

Updated by Carlisle, Timothy over 9 years ago

ok well the IT guys have now installed ROOT v5.30.03, so I can try again, sourcing their installation, if helpful/useful?

#13

Updated by Tunnell, Christopher over 9 years ago

The dependencies (since it's a group install) are hard to tell the IT guys to install since they want a list of packages. ROOT doesn't build separate from MAUS so...

#14

Updated by Rogers, Chris about 9 years ago

Great! Did you see the dependency list here:

http://micewww.pp.rl.ac.uk/projects/maus/wiki/Install#Scientific-LinuxRedhatFedoraCentos

Yes, would be interesting to know if the build script works also.

#15

Updated by Rogers, Chris about 9 years ago

Oops, that was Tunnell, not Carlisle. But did you check that those dependencies are in? If so, the rest of it should build??

#16

Updated by Rogers, Chris about 9 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

I guess this has been resolved. Reopen if it's still bugging

#17

Updated by Rogers, Chris about 9 years ago

  • Target version changed from Future MAUS release to MAUS-v0.3.2

Also available in: Atom PDF