Project

General

Profile

Bug #1040

Releasing open outer door doesn't drop PPS search

Added by Nebrensky, Henry almost 12 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
High
Category:
Safety
Start date:
06 July 2012
Due date:
23 July 2012
% Done:

100%

Estimated time:

Description

During the PPS test yesterday (eLog 2109), we tried a controlled access with both SC and RF Test permits active.

If the door release button is let go while the airlock outer door is open, the search is NOT dropped like it used to be.
This conflicts with the requirement for the operator to deliberately drop the search by this means, should they see someone attempt to tailgate into the airlock.

Note that what we didn't do for lack of time is to check whether this is a change to the underlying system, or a "feature" associated with the permits that we haven't really used before.


Related issues

Related to Operations - Bug #1047: Service of PPS door hardwareClosedMacWaters, Craig 12 July 2012

Actions
#1

Updated by Coney, Linda almost 12 years ago

I'm not sure about the RF permit, but while at the CM I re-checked the parameters for the SC permit.

To be clear - you had searched the Hall, gotten the Hall Ready, Muon Beam Permit, and SC permit. Then you changed to a Controlled Entry state. You sent one person in. Before taking a key out to enter the Hall, you let go of the button in the MLCR while the outer door was open. You observed that the outer door was open, the button released, and the Hall Search was not lost? Did the SC permit remain engaged?

According to the PPS specification document, what you see may be at least in part by design.

It is odd that the Hall Search was not lost. Unless there's some detail I'm missing. I would need to look at the logic diagram.

However, if the SC permit remained ON, then that was correct. Even if the search had been lost, the SC permit should have stayed ON.

The PPS SC permit enables the electrical supplies for the SC magnets. These remain ON during controlled access. And the SC magnets ON lights are illuminated when the permit is ON.

These three conditions are also set by design:

1) The SC permit is cancelled if the permit key is switched OFF

2) The SC permit is CANCELLED if the Hall search is lost by any of these three conditions:
a) a BOB is pressed
b) any of the Hall's external doors are opened (ex. by use of break-out button)
c) both Controlled Entry doors are opened simultaneously

3) The SC permit is NOT cancelled if the Hall Search is lost in any way other than the three just described. If the Hall Search is lost some other way, then the Hall will remain in Controlled Entry. This prevents free access to the area. The magnets will remain at current until ramped down by MICE operators.

We'll have to test this more and understand exactly how it is supposed to work.

From the elog entry - it looks like all of the SC permit behavior was as it should be.

#2

Updated by Nebrensky, Henry almost 12 years ago

OK - I realised that I'd got confused between the search dropping and the Hall going into Free Access, so the PPS did what it should (as it usually does):

  • when the outer door was open when the button was let go, the Controlled Access state remained, but the search dropped, hence we were able to then open the inner door to then drop the permit and get Free Access
  • what I didn't do in the rush was check the search status on the SCP or mimic - my fault
  • I still have the nagging feeling the RF Test Permit stayed on - need to repeat all this properly

I'd like to do some more PPS tests this week to make sure I get what it's doing.

Potential action items would be:

  • We need to think about what to do re. tailgating when SC permit is on
  • Controlled Entry procedure needs to include check on Search status
  • No obvious visible indication to the MLCR operator that search has been lost. Talked to Craig - possibly we could get a "Hall Searched" LED added to the door release control panel in the MLCR?
#3

Updated by Nebrensky, Henry almost 12 years ago

Update on last night's PPS test (eLog 2111):

We repeated last week's drop of the search while SC Permit active several times, but with subtle variations; indeed the SC Permit is retained but the search is dropped and the RF Test Permit (only other one allowed during a CE) is dropped, and the Controlled Entry system remains active. So comes from me being in a rush and overfamiliar with the system, and the lack of an obvious indication of search integrity - hence the idea of a "Hall Searched" LED. At present the operators might not notice the search drop until the CE is over and the 2-minute sounders don't go off.

We also tried a couple of emergency exits through the CE doors in both CE and full running modes. No problems, but noticed that if the Personnel/inner Door is left ajar, then someone running out of the Hall might go through it without hitting the crash-out button and then get stopped by the magnetically-locked Outer Door. Training might need to specifically point out the airlock BOB.
First course of action will be to improve closure of the inner door - issue #1047.

Finally, it appears to be possible to get the RF Test Permit in the MLCR, even while someone is working in the cage - I assume there'll be local isolation anyway. (Need to confirm: we tried with the cage door wide open, but no-one in the Hall).

#4

Updated by MacWaters, Craig about 11 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Will add sounder to indicate search dropped when sc permit in place. See more recent PPS maintenance issue.

Also available in: Atom PDF