Project

General

Profile

Bug #1031

Installation problem on Scientific Linux 6.2

Added by Pradhan, Neetish about 9 years ago. Updated about 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Build System
Target version:
Start date:
22 June 2012
Due date:
% Done:

0%

Estimated time:
Workflow:
New Issue

Description

I ran the MAUS installation on a fresh install of Scientific Linux 6.2. The installation seemed to be completed, but the tests showed some errors. When I checked the install log, there was something about a fortran 90 compiler not being found, in the section where numpy is supposed to be installed. I think it shows at the end of the tests, that 0% of numpy, matplotlib, etc. has been installed.

I tried running MAUS afterwards, but it couldn't load several of its classes. I've attached the install log. (GCC version: 4.4.6-3)


Files

install_log_std (3.89 MB) install_log_std Pradhan, Neetish, 22 June 2012 19:06
#1

Updated by Rogers, Chris about 9 years ago

  • Category set to Build System
  • Assignee set to Rogers, Chris
  • Target version set to Future MAUS release

Are you sure you installed all of the dependencies in the install guide? I recall we saw this before on the RAL machines and I think it was a dependency issue. I can try to dig through old issue trackers...

#2

Updated by Pradhan, Neetish about 9 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Yes, I'd installed all of the dependencies. Update: It seems to have fixed itself. The problem seemed to be using a symbolic link for the maus root directory before installing maus.

#3

Updated by Rogers, Chris about 9 years ago

  • Status changed from Closed to Rejected
  • % Done changed from 100 to 0

Yeah, that's a ROOT feature in fact (and is written in the install guide).

I added a test recently that would even check for such symbolic links so hopefully it will complain next time...

Also available in: Atom PDF