Project

General

Profile

Bug #1984

MAUS 3.2.0 installation issue

Added by Langlands, Joe 2 months ago. Updated 27 days ago.

Status:
Closed
Priority:
Normal
Category:
Installations
Target version:
Start date:
17 January 2019
Due date:
% Done:

100%

Workflow:
New Issue

Description

I have been trying to install MAUS v3.2.0 from the tarball, however it fails during the build.

I have attached the install log.

install.log Magnifier (17.7 MB) Langlands, Joe, 17 January 2019 16:00

install.log Magnifier (1.04 MB) Langlands, Joe, 23 January 2019 15:17

History

#1 Updated by Franchini, Paolo 2 months ago

  • Assignee set to Franchini, Paolo

#2 Updated by Franchini, Paolo 2 months ago

Joe, do you have a previous (working) MAUS version with third party you can link for this one?

#3 Updated by Langlands, Joe 2 months ago

I have tried installing it whilst linking it with Victor's MAUS installation third party. However when I do this it fails whilst running the unit tests and complains about not being able to import _MapPyBeamlineSimulation. I have attached the install.log for this case.

Interestingly, when I use Scott/Victors installed MAUS, I can get data out fine but if I try to run a simulation it complains the same way:

ImportError: No module named _MapPyBeamlineSimulation

#4 Updated by Franchini, Paolo 27 days ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Thanks CR for sorting this out. Numpy needs to be updated to a more recent version in the MAUS third party libraries.

Also available in: Atom PDF